Logitech harmony automatically switches off one device when switching activities

alhf94

Novice Member
I've got a logitech harmony universal remote and kef lsx speakers. I have the TV remote synced in the watch tv activity and the speakers synced in the listen to music activity of the remote. The problem i have is when i click watch tv the tv turns on and it automatically switches off the speakers and when i click the listen to music activity button it automatically turns off the tv and turns on the speaker. Obviously i need both devices to be turned on at the same time, do you know how i would go about this?
 

logiciel

Moderator
When you set up the activity you’re asked to specify which device provides the sound.
 

logiciel

Moderator
Indeed. “When you set up the activity you’re asked to specify which device provides the sound”
 

gcogger

Active Member
Indeed. “When you set up the activity you’re asked to specify which device provides the sound”
Are there different versions of the software? I'm using the MyHarmony Windows app for a Harmony 700. The first step in creating an activity is to select all the devices to be part of the activity (the speakers would need to be ticked in the OP's case). It later asks which device controls the volume (again, that would be the speakers).
To the OP - which remote is it, and what software are you using to set it up?
 

logiciel

Moderator
They all include that basic requirement.
If applied correctly it works.
 

alhf94

Novice Member
Not 100% sure what I've done but now both devices can be controlled simultaneously. To control the KEF speakers I select the KEF amp in the devices section and then back out of it when I want to go back to the TV.

Because I am using an optical cable to connect the speakers to the TV the volume buttons when the TV is selected are useless. I have to change to the KEF in order to change the volume. Is it possible to reprogram the volume buttons to go to the KEF speaker and all the other buttons on the remote stay as they are. So two devices are being controlled without changing the device within the remote everytime I want to adjust the volume. Not sure how clearly I've made this message, if you know what I am getting at please let me know if it can be done
 

Inked

Distinguished Member
Re-run your activity set up making sure that the speakers are part of the activity. During set up, make sure that the speakers are selected as providing the sound and that’s it.
When running the watch TV activity, they will all turn on correctly and you’ll have volume. Control of the speakers within the activity as well as TV controls
 

FazerThou

Well-known Member
Or add a new activity of "watch TV" and when asked add the speakers to control volume, then rename the activity to TV & Speakers so you then have a choice
 

logiciel

Moderator
Devices are not used for control.
That’s done in Activities.
Do as Inked and Faver say.]
It’s the way that Harmonys work.
 

dion 6

Active Member
As the guy's above said add a new activity I've just got a new amazon echo and I added a new activity called it listen to music it switches the tv off and sets the avr to Bluetooth mode I just tell alexa to connect to Bluetooth and I get the music through my 5.1 system
 

The latest video from AVForums

LG CX Best Picture Settings
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom