1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Linn Knekt amps faulty

Discussion in 'AV Pre-Amp/Processors & Power Amps' started by northernmunki, May 20, 2005.

  1. northernmunki

    northernmunki
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi,

    I have two faulty Linn Knekt amps and my mate wants me to fix them, they power on and light up by I dont get any sound out of them. Is this a 'known' issue, what can I do?

    Cheers
     
  2. rowlandhills

    rowlandhills
    Active Member

    Joined:
    Feb 9, 2005
    Messages:
    427
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Baldock
    Ratings:
    +18
    When you say "Knekt" amps, do you mean Knekt Roomamps?

    If so, do you have an RCU (Room Control Unit) plugged in? If not, I don't think you'll get anything out of it, as you have no control on source selection or volume. It may well be set to remote audio rather than local anyway.

    Rowland
     
  3. northernmunki

    northernmunki
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Thanks for the reply. Yes they are the room amps. RCU works fine, as i've done a direct swap with another and all is good.
     
  4. rowlandhills

    rowlandhills
    Active Member

    Joined:
    Feb 9, 2005
    Messages:
    427
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Baldock
    Ratings:
    +18
    Sorry if I was pointing out the obvious! :)

    Other than that I don't really know, I'm afraid. I'm a user, rather than a dealer/maintenance guy...

    The one thing I do know is that Linn have a fixed price repair service. Obviously your mate would like you to fix them on the cheap, but £150 (which is what I've been charged to have my AV5125 repaired) is a lot less than a new roomamp!
     

Share This Page

Loading...