Lights are on, but nobody's home?

gop

Member
Hi folks, I'm hoping yous can help me out here.
Specs: ASUS X470 prime pro motherboard
Ryzen 7 2700x max cpu.
EVGA 850 GQ, 80+ GOLD 850W, Semi Modular, EVGA ECO Mode, Power Supply 210-GQ-0850-V3
G.Skill 16GTZRX TridentZ RGB DDR4 16 GB PC 3,600 CL18 x2

Samsung 1TB 860 evo ssd x2
Hauppage wintv quad dvb tuner
Corsair CC-9011030-WW Carbide Series Air 540 ATX High Airflow Cube Performance Windowed Computer Case - Black

So, a few days ago, I turned on the plug to an extension lead, the computer is connected to this with tv and avr. I heard a loud bang from the speakers, which tripped the main breaker. Sorted that, tries truning on the computer, but nothing. Done the pin test, it's dead. Ordered same psu, checked it work with a meter (YBLNTEK 20/24 4/6/8 PIN Computer PC Power Supply Tester For ATX, ITX, BTX, PCI-E, SATA, HDD), now here's the problem: the lrgb lights are on the mobo, but the system won't turn on. all psu leads are connected in the right place. I can't remember if the g-skill rgb memory sticks also light up when power is just running but system not turned on.

Anyone any ideas as to get this running. I'm assuming, the surge only fried the psu, as the mobo lights are on?

Many thanks in advance.

G
 

Bolosun

Member
Remove everything from the motherboard and retry. Be very careful if it works and you start adding the devices back on, it may blow it again. If it went bang have a look closely at the motherboard and the parts and see if you can see any burn marks on anything,
 

JollyJamma

Active Member
Do what Bolosun suggests.

Try get the system to POST with only basic devices added (display, 1 RAM stick, power cables).

You may have a short that has blown all the attached devices but hopefully it's just a dead mobo.
 

gop

Member
Thanks for replying. The bang was from the speakers, no device was actually turned on yet.

I had tried removing all devices, wouldn't turn on. Got a new psu same model, turns out, using the old sata cables was stopping it.

So, I can get it to bios, but the bios won't recognise any bootable drive. I've enabled that cms, changed from ueifi to legacy, no joy. I've tried different sata ports, still nothing. I think it may have fried the sata ports and the 2 ssd. I connected them both to a different pc, restarted, they didn't appear as an additional volume.

I'm looking now is there is a sata hub that could be connected either pci or molex, or USB?
 

gop

Member
Thanks, I ordered a USB to sata converter, only £5.99. Just to see if the bios will read that, or if the pc that is working will pick it up.

I've read somewhere to disconnect everything connected to the mobo, even the cpu, does this sound like it'd be effective?

I'm still using the old psu cables for the cpu and vga, should I swap those out, they're functional, as I can see the bios, which picks up the ryzen 7 and 4 ram sticks.
 

DavidG1

Active Member
I ordered a USB to sata converter,
It is unlikely this will be picked up in the BIOS as the USB drivers won't be available at the BIOS stage. These adapters are usually used after windows has loaded
 

The latest video from AVForums

AVForums Movies Podcast: Streaming Theatrical Releases And The Future Of Cinema
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom