LG UK6500EJD - HDR mode forcing itself on [without user control] for HDMI inputs and losing signal.

aeioux

Novice Member
Hi guys, first post for me hoping to get some insight into this.

Just picked up a LG TV UK6500EJD here in Japan.
It's not practical for me to be doing tech enquiries with LG Japan due to language barriers.
Hoping for some insight here with related LG 65** models. Mines a 2018 model.

Connecting my (Windows 10 64-bit) Gaming PC to the TV via a brand new HDMI 4K compatible cable, and the TV is repeatedly forcing itself into 'Ultra HD Deep Color' mode, which then causes the LG OS to struggle, freeze, then the image from the PC then disappears.

I am then struggling to re-access the full options to manually disable the 'Ultra HD Deep Color' mode, when I do so, the TV will then re-detect a possible HDR signal from my PC and force it BACK ON.

There are no settings to disable this unwanted automatic switching.

All my Windows 10 HDR settings are disabled (Windows Control Panel, and nVidia Control Panels).

LG OS is updated (04.10.40)

Any thoughts gratefully received - thank you :)

Chris
 

Attachments

Last edited:

aeioux

Novice Member
Latest update is that connecting to HDMI 4 input, has currently resolved this.

The LG OS suggests that the 'Ultra HD Deep Color' mode can be enabled on any of the 4 main inputs, but whether I've tricked it into staying locked on the input that caused the problems (#1) and moved to a different input, is yet to be seen.

I checked the LG OS was updated, and apparently it was. I also updated my NVIDIA graphics card drivers also to be sure, but I don't actually believe either of these things were the issue.

I'll keep updating as I go, this does appear to be a real issue that may be experienced by others with a similar setup.

(Admins please don't close this thread just yet, in case of ongoing issues - it's only 2nd day ownership of this TV).

Thanks!
Chris
 

aeioux

Novice Member
TV was fine until I started up Star Wars Battlefront II from my PC;

TV then detected a 'HDR' signal and went back through the annoying cycle detailed above.

What really doesn't help is LG's annoying OS which requires jumping through many hoops to navigate back to the 'Ultra HD Deep Color' option:

Home > Settings > nav to bottom of list for All Settings > Picture > down 3 to Additional Settings > down to HDMI ULTRA HD Deep Color then to the relevant HDMI #, click to toggle off.

Have now tried this on all HDMI inputs and the same problem persists.

During this process the TV actually updated its firmware, with no change to the problems I'm detailing!

This TV is going back to the store by the looks of it, unless anyone from LG is reading this and can advise very quickly. :mad:

Chris
 

aeioux

Novice Member
Latest update is that disabling DirectX 12 within Star Wars Battleground II (note that HDR settings in the game were already disabled) seems to have stopped triggering the HDR detection on the TV. However the HDR did trigger from other sources before I tested SWBG2 so I'll keep testing and report any further findings.
 

next010

Distinguished Member
Latest update is that disabling DirectX 12 within Star Wars Battleground II (note that HDR settings in the game were already disabled) seems to have stopped triggering the HDR detection on the TV. However the HDR did trigger from other sources before I tested SWBG2 so I'll keep testing and report any further findings.
Leave HDR controls in Windows 10 disabled (settings->system->display->advanced) as these force Windows into HDR when its not nessecary and check any game on the PC gaming wiki that has native HDR to disable that feature if present in the games settings. You should be able to leave Ultra Deep colour enabled with this.

For LG's PC mode you must change the HDMI input icon to PC icon in WebOS input manager to activate RGB 444 mode.

LG's PC mode can have some banding effects, depends on how sensitive to that you are, if they do bother you switch to game mode preset on the TV and in your Nvidia GPU driver control panel under resolution select Nvidia color settings and convert the video output to YCC 444 or RGB Low 16-235 (dynamic range).
 

aeioux

Novice Member
Many thanks for the very useful feedback next010 👌

"For LG's PC mode you must change the HDMI input icon to PC icon in WebOS input manager to activate RGB 444 mode."

Wow, that is an incredibly hidden feature! :eek:
I did happen to do this during the process which may have contributed to the improved stability overall.

As mentioned, regardless of the handshaking/tech specs going on behind the scenes, the fact that LG is forcing an option ON without offering user choice (as per my screenshot attached in the OP) is somewhat bewildering.

LG; I would request that you allow and respect - users choices for the 'Ultra HD Deep Color'.

Many thanks again,
Chris
 

aeioux

Novice Member
Quick guide for a stable display on LG TV UK6500EJD (2018 model) from Windows 10:

Key problem encountered was the TV auto-forcing itself into 'Ultra HD Deep Color*' mode when it detected HDR input from my PC, resulting in the image disappearing and having to manually disable the *UHDDC mode manually deep within the settings. This was resolved by following the procedure below—

1 - Ensure you are using a HDMI 2.0 or 2.1 cable
2 - Ensure the HDMI input on the LG TV is set to the PC ICON (most important step)
3 - Ensure that Windows 10 HDR settings are disabled (look for the Windows HD Color Settings options screen)
4 - If you are playing games, ensure HDR settings are disabled within each game

Some commenters have suggested steps #3 and #4 maybe skipped once #2 has been set, offering HDR images, but I simply want a stable connection for now so have not tested these.

Hope this helps somebody else out there 👍

Thanks again,
Chris
 

Similar threads

Top Bottom