LG UBK 80 BD Player No Video Output

WileyMarmot

Novice Member
Bought an LG UBK 80 BD player yesterday, 9/5/21, as a replacement for my old (dead) Sony BD player. All cables and components in my system are 4K compatible. All I had to do was set the UBK 80 in place, plug in the existing HDMI cable to the back of it, and plug in the power cord to the surge protector.

The HDMI is connected to the BD/DVD HDMI input on the back of my Onkyo RZ 810 AVR, and is outputted to HDMI 1 on my Vizio TV. When the system is powered up and the TV input is switched to HDMI 1, and the AVR to BD/DVD all I get is a black screen on the TV. No BD player menu (no disc in the tray), nor a BD disc menu (disc in the tray).

FYI: I have not used the optical audio output on the UBK 80 because: Figured as the old Sony BD player outputted both video and audio over the HDMI cable this LG should too, and I've only got two optical audio inputs on the AVR and they're both is use.

Any ideas, suggestions, advice, etc? TY!

BTW: I've sent this issue into LG customer service; awaiting a reply from them at this time.
 

goingoingong

Distinguished Member
Bought an LG UBK 80 BD player yesterday, 9/5/21, as a replacement for my old (dead) Sony BD player. All cables and components in my system are 4K compatible. All I had to do was set the UBK 80 in place, plug in the existing HDMI cable to the back of it, and plug in the power cord to the surge protector.

The HDMI is connected to the BD/DVD HDMI input on the back of my Onkyo RZ 810 AVR, and is outputted to HDMI 1 on my Vizio TV. When the system is powered up and the TV input is switched to HDMI 1, and the AVR to BD/DVD all I get is a black screen on the TV. No BD player menu (no disc in the tray), nor a BD disc menu (disc in the tray).

FYI: I have not used the optical audio output on the UBK 80 because: Figured as the old Sony BD player outputted both video and audio over the HDMI cable this LG should too, and I've only got two optical audio inputs on the AVR and they're both is use.

Any ideas, suggestions, advice, etc? TY!

BTW: I've sent this issue into LG customer service; awaiting a reply from them at this time.
Have you tried connecting the player directly to the TV and not through the Onkyo?
 

WileyMarmot

Novice Member
I'll give that a whirl as well as trying a different HDMI input on the AVR. I've already checked the HDMI cables for damage and being firmly connected.

The old Sony suddenly stopped reading all discs, but worked fine the evening before, and "after" dying it still displayed the Sony splash screen/main menu on the TV, unlike this LG.

TY!
 

The latest video from AVForums

Podcast: Sky Glass, Epson Laser Projectors plus Home Cinema Subwoofers and More…
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom