Quantcast

Question LG TV using HDMI ARC with Sonos

JAy3001

Active Member
So I have just purchased a Sonos Beam to go with my 2 Play:1s and it all sounds great. However...

Using the HDMI ARC port seems to cause a minor issue, that I cannot stop the sound coming out my Sonos kit.. ever!

To return my sound to my TV speakers I have to select it within my TV settings, which works for about 3 seconds before the sound returns to HDMI ARC.

Now I have spoken with Sonos and they said the TV must be calling for a signal returning the sound back to ARC.

Which of course means I cannot turn the Sonos sound off, which is a bit of pain as I really don't want surround sound 24/7. At low volumes it seems pointless, although nice and it can be enhanced by turning on the enhanced spoken dialogue option.

Still I would like a way to return the sound back to the TV speaker without having to unplug the ARC cable!

So are there any other LG TV owners out there with a Sonos Beam that can test this out and see if it's the same for them please?

My model is: 43UK6300PLB

Another issue seems to be that turning my SkyQ box on no longer turns the TV on, linked to the ARC port being active maybe? Simplink?
 

NeilH

Active Member
It's a 55B8S. Only connections are the Beam and a Sky box.

The options on Sound menu are the same as yours with the addition of :

- Audio Out (Line out)
- Wired Headphones

These are located immediately below "Device Selection".

Hope this helps.
 

JAy3001

Active Member
Thanks Neil.

I've found a workaround by using the optical adapter, this stops the TV from switching back to ARC allowing me to select the TV speakers.

I believe this will only effect Alexa's ability to switch the TV on or off and maybe the volume controls from TV remotes. Not the end of the world especially as I only managed to get Alexa to switch the TV on and off once, afterwards she would say "ok" and blatantly ignore me. :rolleyes:

Anyone else have the issue with HDMI ARC?
 

AdamsC8

Novice Member
I may be late to the party, but I have the same issue. I found a solution by turning HDMI+ off.
I have a new issue, though. Since updating to the latest firmware, my TV speakers don't work when I toggle to them.
 
Last edited:

AdamsC8

Novice Member
it's in the General menu. I think the name is HDMILINK+; I'm not home to look, but it's something like that. Turn that guy off when you don't want to use it, and then on when you do.
 

Similar threads

Top Bottom