LG PF50K projector's simplink (ARC-CEC) unstable with HDMI to optical audio extractor.


Novice Member
Hello all, I have been intending to connect an old 5.1 receiver (optical input only) with the LG PF50KS projector (FW 03.00.15) which has only HDMI-ARC for digital audio output. The product I got to do the conversion is the AMANKA HDMI ARC audio extractor (I will call it "extractor" from now on).

The problem:
When the extractor is attached to the projector, simplink understands the connection and automatically switches to HDMI(ARC) output, but half a second later it fails to perform a stable registration and reverts back to the projector's internal speakers. Then this switching back and forth between internal speakers and ARC output continues repeatedly.

What I tried:
  • Connecting the extractor to another TV that has the ARC feature and it worked flawlessly, so the device is not defect.
  • All kind of standard troubleshooting like connection order, power cycles, different cables, various (if not all) combinations of settings.
  • The optical input of the extractor. Also worked.
  • Connecting or not the receiver with the extractor does not matter, since the behaviour happens by just connecting the extractor to the projector.
What I have not tried:
  • Another ARC compatible device to test if the/my projector's simplink works well with other devices.
  • Downgrade to other firmware, since I did not find any method (nor firmware anyway) to do so.
  • Rooting the projector (if possible).
An inconvenient workaround:
I accidentally found out that when the projector is trying to register the extractor as ARC output, if I press repeatedly the volume button, although it does nothing to the volume since the specific extractor does not have volume functionality, after some effort the connection is registered, as if I force the handshake to be done. Apart of inconvenient the workaround is also not permanent to not care.

My thoughts:
I suspect there is a compatibility issue with simplink and the specific extractor device or with the specific firmware and simplink or with my projector at least. As noted I have not tried another ARC compatible receiver. I can only add that I have a chromecast, which when connected "simplink supported" is stated, while for the extractor is not. The extractor is only ARC compatible, since there is no operation to be controlled by CEC. Simplink is designed for both features. I am wondering if what is called CEC-less adapter would help, although I doubt it since the extractor has worked with the other TV.

My questions:
Any suggestion for what causes this behaviour? Is there any way to downgrade the projector's firmware? Any solution to similar misbehaviour?

The latest video from AVForums

Samsung QN95B 4K QLED TV Review
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom