LG OLED55C14LB Need a little help with HDMI 2 label

Weirdbeard

Novice Member
Joined
Nov 1, 2021
Messages
4
Reaction score
0
Points
1
Age
60
Location
Plymouth UK
On Saturday I setup my OLED55C14LB and overall I'm happy with the results. I do have an issue with the input labelling though, which I seem to be unable to resolve.

I have a Yamaha RX-V679 AV Receiver connected via HDMI OUT ARC to HDMI 2 ARC/eARC on the C1. During initial setup I had the receiver switched on and connected to the TV while it went through the tuning and login process. When all was done, I noticed that HDMI 2 had been labelled "Kodi".

IMG_20211101_162035566.jpg


At that time the RX-679 had a Virgin Tivo box connected to HDMI 2 (labelled on the receiver as " Virgin") and a PC connected to HMDI 3 (labelled on the receiver as "PC").

I did experiment with Kodi a few years ago on the PC (which I mainly use for games) but I don't recall ever renaming/relabelling any Inputs or Outputs on any piece of equipment with "Kodi".

I'm baffled about where this "Kodi" label has come from, but even more confused about how to get rid of it.

Things I've tried:
  • Home Dashboard - Edit Inputs - HDMI2 is missing entirely as an option to edit.
  • Went through "Universal Control" setup multiple times - Yamaha receiver is recognised and Power and Volume of receiver work fine through the tv remote.
  • Hidden Menu (via Mute button spam) AV RESET - HDMI 2 is then recognised as " Yamaha Home Theatre" , which is great, until ARC is selected in sound output options. As soon as I do that a "Simplink" message pops up and the label simultaneously reverts to " Kodi".
  • Factory Reset - Reset to Initial settings. Again, when I select ARC for sound output, "Kodi" pops right back as the label.
  • I've been through every input label on the receiver itself, without finding "Kodi" mentioned anywhere. Also I scoured the receiver manual looking for an "Output" label setting that the LG might be picking up, but other than the network name and the Zone ID's which are all still default, I can't find one.

I'm aware of my advancing years and that the problem is probably situated between the remote and the sofa, but I just want to rename HDMI 2 to anything other than "Kodi" and any insight on how I might achieve this is would be most welcome.

EDIT: I've since discovered that if Simplink is disabled, the HDMI 2 label appears in "Edit Inputs" and can be changed. But as soon as Simplink is enabled the Kodi label appears again and overrides my edit. In fact you can watch it change back and forth by toggling Simplink on and off. As i need HDMI-CEC functionality, leaving Simplink disabled is not really an option.
 
Last edited:
That's both strange and interesting, never seen that before.

LG does have a database of devices, that it auto brands with a label perhaps there is some kind of mistake in the database and it looks at that Yamaha and assigns it the incorrect label of some other device that runs Kodi.

Is the TV connected to the internet ?
  • disconnect from internet
  • unplug Yamaha from TV
  • perform factory reset
  • power off the TV from wall power socket for 10 minutes (LG keep a database of recent devices stored in service menu)

Now power back on the TV and leave it off the internet and connect the Yamaha, see if it auto brands it as Kodi, if so whatever is doing it is in the firmware.

A possible workaround is the Sharc, an eARC bridge for older sound systems, this would present as a different device to the TV and give you PCM 7.1 and Dolby TrueHD 7.1 over eARC so its not just a name change your getting something from it. However if you plan on using HDMI inputs of the AVR this is not possible with sharc.
 
That's both strange and interesting, never seen that before.

LG does have a database of devices, that it auto brands with a label perhaps there is some kind of mistake in the database and it looks at that Yamaha and assigns it the incorrect label of some other device that runs Kodi.

Is the TV connected to the internet ?
  • disconnect from internet
  • unplug Yamaha from TV
  • perform factory reset
  • power off the TV from wall power socket for 10 minutes (LG keep a database of recent devices stored in service menu)

Now power back on the TV and leave it off the internet and connect the Yamaha, see if it auto brands it as Kodi, if so whatever is doing it is in the firmware.

A possible workaround is the Sharc, an eARC bridge for older sound systems, this would present as a different device to the TV and give you PCM 7.1 and Dolby TrueHD 7.1 over eARC so its not just a name change your getting something from it. However if you plan on using HDMI inputs of the AVR this is not possible with sharc.
Hey there.

Thanks for the suggestions. It hadn't occurred to me that the labelling might be coming from an online database. I'll try this shortly and feedback.

The Sharc workaround looks interesting, but I might be tempted to offset it's cost against that of a new AVR if all else fails. In all other regards though this Yamaha still fits my needs, so I'm hoping it doesn't come to that.
 
That's both strange and interesting, never seen that before.

LG does have a database of devices, that it auto brands with a label perhaps there is some kind of mistake in the database and it looks at that Yamaha and assigns it the incorrect label of some other device that runs Kodi.

Is the TV connected to the internet ?
  • disconnect from internet
  • unplug Yamaha from TV
  • perform factory reset
  • power off the TV from wall power socket for 10 minutes (LG keep a database of recent devices stored in service menu)

Now power back on the TV and leave it off the internet and connect the Yamaha, see if it auto brands it as Kodi, if so whatever is doing it is in the firmware.

A possible workaround is the Sharc, an eARC bridge for older sound systems, this would present as a different device to the TV and give you PCM 7.1 and Dolby TrueHD 7.1 over eARC so its not just a name change your getting something from it. However if you plan on using HDMI inputs of the AVR this is not possible with sharc.

Ok I've tried this now, but even with the Internet disconnected, the TV still relabels the Yamaha AVR on HDMI2 as Kodi when Simplink is enabled.

On a positive note, I am becoming quite adept at whizzing through the first time setup process.
 
Turn on Tv, Turn on AVR. Turn off Avr. Go to home dashboard app on TV and edit name of Hdmi 2. I have noticed that hdmi name can be edited when it isn't in use.
I had also a problem with labels. My avr have 4 devices connected. Ps3, Ps4 pro, XSX and nvidia shield but TV recognised labels only for first 3 devices. Connection order:
1 Xsx
2 nvidia shield
3 ps3
4 ps4 is not recognized and is visible on tv as ps3
Another try
1 ps3
2 nvidia shield
3 ps4
4 Xsx is not recognized and is visible on tv as ps4

but to be honest it works anyway. The only problem i had was when the following issue occurred: tv turns on automatically the last used device but looks like this no longer happen.
 
Thanks to those who offered suggestions. It is appreciated.

The issue lay with a forgotten Pulse-Eight USB-CEC adapter attached between the HDMI out on the PC and the HDMI cable feeding the TV/AVR.

It had previously been configured to allow HDMI-CEC control of a long gone Kodi setup and was still trying to fulfill its purpose after at least 4 years.

Even with the PC fully shut down (but still connected at the outlet), the adapter was receiving power from the PC's USB socket and broadcasting "Kodi" to anything that would listen.

This didn't happen on either of the two previous Panasonic TV's it was attached to (TX-55CR852B & TX-55GZ1000B) which probably contributed to me forgetting it was ever there.

The fix was to remove the adapter and reconnect the HDMI cable directly to the graphics card.

Everything regarding the C1's input labels, HDMI-CEC behaviour and device recognition then fell into place and functions as expected.

No more Kodi label.

I was a bit too stubborn to just toss the adapter though, so I re-installed Kodi and re-configured the adapter to behave itself.

It's now in a drawer for the foreseeable future. I don't want to see "Kodi" again for a while.

Thanks again.
 
Google was my friend to find this, I have an almost identical set up and just wanted to say thank you.

It's helped me understand the eArc process and where the TV pulls the names from. Had a slightly different Shield related issue where the TV would change my receiver to the wrong input. Turned out to be under the Shield power control settings which I hadn't even considered.
I use a harmony remote to configure the other devices and set ups so was driving me crazy!

Thank you
 
Still confused by this. Have an LG C2 and DENON AVR-X1700H. TV will not let me change the 3 names it has for LG HDMI 2 (eARC connector to DENON HDMI Monitor connector). Would like to change all 3 names to “Theater”. Anyone know how? Thank you.
 
I am having a similar problem but cannot find a solution. I have a Denon AVR-X6300H receiver plugged into the ARC HDMI Channel of the LG TV. (HDMI2). The LG TV is labeling this input as "Living Room" Not sure where this label is coming from. I am unable to change the label to something else. HDMI2 does not show up as an input where I can change the label. I have tried all the solutions listed above. Nothing works. Any advice?
 
I found my Apple TV was muscling in on the name change. You could rename the ATV to what you desire but then that might not sit well either.
 
I am having a similar problem but cannot find a solution. I have a Denon AVR-X6300H receiver plugged into the ARC HDMI Channel of the LG TV. (HDMI2). The LG TV is labeling this input as "Living Room" Not sure where this label is coming from. I am unable to change the label to something else. HDMI2 does not show up as an input where I can change the label. I have tried all the solutions listed above. Nothing works. Any advice?

If you completely power off whatever is connected to HDMI2 you can then change it's name in the Edit Inputs menu. For some bizarre reason you can't do this when it detects something is connected.

However, even when it's name has been changed it will still show HDMI2 for other devices that use that Input e.g an ATV4K connected via an AVR.

I changed HDMI2 to Home Theatre and the only time that label ever pops up is when I switch the AVR on after the TV. It flashes up 'Home Theatre Available' at the bottom of the screen.

The Inputs menu still lists HDMI2 for everything.
 

The latest video from AVForums

LG G4 OLED Best Picture Settings Out Of The Box - Filmmaker Mode!
Subscribe to our YouTube channel
Back
Top Bottom