LG OLED B9 Owners and Discussion Thread

Inferno

Distinguished Member
My b9 just had an update - anyone know what it did ? Now on 5.00.02

Mine got updated the other day, and I've no idea what it has done. :laugh:
 

lowrider007

Active Member
I also received the update today (5.00.02), is this the one that fixes the g-sync?
 

LucidDreams

Active Member
Hi

My oled panel has started to develop a faukt where the screen will intermittently go black . The only way to resolve this is to power it off and on again. This fixes the issues but it reoccurs about 10 minutes later. As you can appreciate this renders the TV useless.

I have performed a factory reset and disconnected other devices but the problem persists. Is this a recent firmware upgrade problem? as the issue has only occurred within the last month or so, and I noticed the new setup menus are different.
I read that turning of pixel shifter may help.

Shame they cannot fix it on site and they have to take the TV away from what I understand. Let us know how you get on with getting it repaired.
 

10000hz

Standard Member
I've already tried that, took an hour or so but no joy. Got a reply from LG , so will follow up their advice .

Will keep updating the thread.
 
Last edited:

Jeff

Distinguished Member
4k 120hz not working with Xbox series, I have 04.80.2 installed, I get No updates found when I check for updates. 😒
 

Inferno

Distinguished Member
20201102_104427.jpg
 

bandyka

Well-known Member
4k 120hz not working with Xbox series, I have 04.80.2 installed, I get No updates found when I check for updates. 😒
Just download it manually.
 

Jeff

Distinguished Member
My TV updated automatically today, unfortunately 4k 120hz still doesn’t work, the signal gets lost as soon as I switch to 120hz. The Xbox series X is connected directly to the TV using the supplied cable.
 

dipps

Active Member
Hi All,

I have an LG OLED65B9PLA and have recently bought a Xbox series X.

I can’t get the Xbox to work in 4K, only 1440p

4K is not even an option.
My original post is here and Iv tried everything


If anyone has any solutions I’d be so grateful, thanks.
 

10000hz

Standard Member
Likewise xbox series X owner, I'm on the latest firmware (05.**) and [email protected] works fine for me. When the picture not going black anyway.

Make sure you're using the supplied cable (hdmi 2.1 )and also deep black option is enabled for that HDMI socket.
 

shagaboopon

Well-known Member
2 weeks down now on the repair and I got a text to say they ordered the parts. So reassuring they wasted 8 days of my time diagnosing it remotely to then have to order the parts once received by the repairer.
 

RickRock

Active Member
Hi All,

I have an LG OLED65B9PLA and have recently bought a Xbox series X.

I can’t get the Xbox to work in 4K, only 1440p

4K is not even an option.
My original post is here and Iv tried everything


If anyone has any solutions I’d be so grateful, thanks.
mine works great, [email protected] no probl.
try disable allm
i have checked in the xbox: vrr, and 422, no allm
 

10000hz

Standard Member
2 weeks down now on the repair and I got a text to say they ordered the parts. So reassuring they wasted 8 days of my time diagnosing it remotely to then have to order the parts once received by the repairer.


Not what I want to hear, they've only just passed my issue to the engineering team, then will be in touch to collect.
 

shagaboopon

Well-known Member
Not what I want to hear, they've only just passed my issue to the engineering team, then will be in touch to collect.

Sorry to hear, the entire process has been pretty woeful for me. Its the sort of service that might have been acceptable 20 years ago.
 

10000hz

Standard Member
Sorry to hear, the entire process has been pretty woeful for me. Its the sort of service that might have been acceptable 20 years ago.

Even with this years troubles I imagine the process wouldn't exactly have been quick. Could've done without the hassle but First World problems and all that eh.
 

Doctor Hades

Well-known Member
Anyone having problems using the mic on the magic remote today or accessing the LG Store on their B9s?

I use the mic to turn the screen off but while it registers what I say correctly, the cursor just spins and eventually Google Assistant says I cannot understand. This was working fine just a few days ago.

Also the LG Store will not load. It says there is No Content.

I thought it might be issue with the internet connection but the NetFlix and YouTube apps both work fine as I am listening to a video right now as I type this.

Tried turning the TV off with the Quickstart+ turned off then turned it on but the issues persist.

*EDIT*
Must be an issue with the LG website because I cannot access the Account Management from settings either. Just loads a bit then says Try Again and clicking OK just exits back to the channel I was on.

*UPDATE*
Turning Quickstar+ off then TV and then turning it back on would not fix this issue. In the end I tried the old trick of unplugging the TV from mains after powering it into standby mode, which is the first time I have done this since I got the TV in August 2019.

Guess what?

It fixed the issue and now the Store works and I can access the Account Management. Also "Screen off" now works.

Just thought I'd post this in case someone has the same issue.
 
Last edited:

Jeff

Distinguished Member
My TV updated automatically today, unfortunately 4k 120hz still doesn’t work, the signal gets lost as soon as I switch to 120hz. The Xbox series X is connected directly to the TV using the supplied cable.
I don’t know if this is what fixed it, but after changing some settings including setting it to PC mode fixed my 120hz issue.
 

killabyte

Active Member
My tv just had the latest 05.*** update. My xbox series x games were working on now I keep on getting a no signal message when I try to load a game.

Any know why? Can someone list what the recommended settings are for the xbox series x and the TV.
 

dipps

Active Member
I’ve tried everything, switching pictures modes turning things on/off resetting them, the XSX just doesn’t see my OLED65B9PLA as a 4K screen! 1440p is a great step up and everything is great but iv paid for 4K gaming and it’s non functional.

This was Microsoft’s last response after exhausting all the setting tutorials they sent me...
Unfortunately, in this case the LG OLED65B9PLA is not compatible, since you tried with the Samsung one and no issues were detected.

Therefore, what you can do Mandip is to get in touch with the manufacturer, and they will check the issue with you, since there is nothing we can do from our end.’


Nothing back from LG either yet, we wait....
 

Doctor Hades

Well-known Member
I’ve tried everything, switching pictures modes turning things on/off resetting them, the XSX just doesn’t see my OLED65B9PLA as a 4K screen! 1440p is a great step up and everything is great but iv paid for 4K gaming and it’s non functional.

This was Microsoft’s last response after exhausting all the setting tutorials they sent me...
Unfortunately, in this case the LG OLED65B9PLA is not compatible, since you tried with the Samsung one and no issues were detected.

Therefore, what you can do Mandip is to get in touch with the manufacturer, and they will check the issue with you, since there is nothing we can do from our end.’


Nothing back from LG either yet, we wait....

My Xbox One X detects my B9 (same model as yours but 55") as 4K, no problem, and shows it as being compatible (all ticked) in the TV Information on the console. Ditto for my PS4 Pro. Both have worked flawlessly in 4K mode at 60 Hz for the year I have owned the TV. I even briefly tried 1440p @ 120 Hz on the XOX but, of course, that console doesn't support 4K @ 120 Hz so that has never been tested. I'm waiting for my PS5 next week to be able to test that (fingers crossed, eh?).

Sounds like there is a bug with the Xbox Series X to me. Looks like you will have to wait for a response from LG on this issue, unfortunately, but as more and more people start owning these systems then the more likely it is that more issues will be reported and, thus,. LG and Microsoft will start to take notice. Bad rep is damaging after all.

*EDIT*
Are you running your XSX through some kind of passthrough by any chance?

I remember when I had Sky Q installed. The engineer set it up as with my Sky+HD setup so that the cable box was connected into my X1X and the HDMI from my X1X was connected to the TV. However, when he went on to setup Sky Q it would not detect my was 4K capable even though everything was using 4K-certified HDMI cables.

Turned out that the passthrough on the X1X was not capable of passing through a 4K signal (IMO a massive oversight on Microsoft's part) so I ended up having to buy a 4K HDMI switcher box so that I could use my X1X in 4K along with my Nintendo Switch as the other 3 HDMI ports were being used by other devices (Sony 4K UHD X800 BD player PS4 Pro, Sky Q). This works fine.

Sorry if I missed one of your posts but I didn't see any mention of testing the HDMI directly into the TV from the XSX.
 
Last edited:

The latest video from AVForums

Podcast: Trinnov Room Optimiser: A full explanation of Trinnov and its room optimiser technology

Latest News

AVForums Podcast: 27th February 2021
  • By Phil Hinton
  • Published
Musical Fidelity launches M3x Vinyl phono stage
  • By Andy Bassett
  • Published
SVS launches 1000 Pro Series subwoofers
  • By Andy Bassett
  • Published
T+A launches new Caruso R music system plus optional speakers
  • By Andy Bassett
  • Published
Melco update adds Roon 1.8 readiness
  • By Andy Bassett
  • Published
Support AVForums with Patreon

Top Bottom