Quantcast

Question LG OLED 65C9PTA does'nt direct play TrueHD 7.1 using Plex Media Player webos app

sranjith

Novice Member
Server Version#: 1.16.3.1402
Player Version#: Plex for LG 4.1.1,
WebOS: 4.6.0

TV: LG OLED 65C9PTA
Soundbar: LG SL9YG + rear Kit (4.1.2 + rear kit) ATMOS,DTS:X

Problem desctiption: When trying to play TrueHD 7.1 audio the plex app transcodes instead of direct stream. The same is not a problem while playing using XPLAY.

Plex Media Server: running on QNAP 453A

Player Settings:
I have enabled AC3, EAC3 and DTS on the audio settings of the player Audio settings

Video Settings:
Direct play and Direct Stream enabled
Local/Remote Quality set to Original
Max H.264 level set to: None

TV Settings:
sourbar connected through ARC
eARC: turned on.
Digital sound out: Pass through

How do I direct Play TrueHD 7.1 content on this setup. I am able to get Atmos on Netfilx with no issues.
 

sagaris99

Well-known Member
Server Version#: 1.16.3.1402
Player Version#: Plex for LG 4.1.1,
WebOS: 4.6.0

TV: LG OLED 65C9PTA
Soundbar: LG SL9YG + rear Kit (4.1.2 + rear kit) ATMOS,DTS:X

Problem desctiption: When trying to play TrueHD 7.1 audio the plex app transcodes instead of direct stream. The same is not a problem while playing using XPLAY.

Plex Media Server: running on QNAP 453A

Player Settings:
I have enabled AC3, EAC3 and DTS on the audio settings of the player Audio settings

Video Settings:
Direct play and Direct Stream enabled
Local/Remote Quality set to Original
Max H.264 level set to: None

TV Settings:
sourbar connected through ARC
eARC: turned on.
Digital sound out: Pass through

How do I direct Play TrueHD 7.1 content on this setup. I am able to get Atmos on Netfilx with no issues.
Dolby TrueHD is lossless, but your setup is not able to play lossless audio over GDMI ARC. I’m confused as to why you are after lossless?
 

sranjith

Novice Member
How can I get Atmos content to play on my setup. If I cant play 7.1 atmos content. I will return my soundbar. It is just a few days old.
 

dion 6

Active Member
As sagaris99 said Dolby True HD is lossless atmos no TV apps stream in lossless atmos its lossy atmos DD+ with atmos metadata thats what you are getting from netflix when it says atmos its not lossless atmos its DD+ atmos
 

sranjith

Novice Member
Update: returned the LG SL9YG soundbar and replaced it with Samsung HW-Q90R. Now I can play Dolby Atmos but not DTS:X content. Soundbar displays Atmos while playing Atmos content but not DTS:X.

HW-Q90R does not have google assistant, Alexa needs a separate device and singapore regions is not supported yet.
Mixed feeling now on replacing the soundbar. So finally I need have to invest on a NVIDIA shield!
 

next010

Distinguished Member
While the C9 supports HD audio over eARC it does not support it over the WebOS media player, they forgot to update it or over looked it.

So yeah you need a Shield to play the audio, you can plug the Shield directly into the TV with eARC and it will send the TrueHD 7.1 Atmos and DTS:X to the Q90.

Be aware also the C9 does not support PCM 7.1 over eARC something else LG over looked.
 

CCSGDM

Novice Member
U can get mibox 3 instead of shield for atmos n dts-x.
My setup: Mibox 3(Kodi) —> Q90R —> C7
Test streaming from NAS n soundbar shows it’s receiving both audio format. Make sure u used a premium certified hdmi cable.
 

sranjith

Novice Member
While the C9 supports HD audio over eARC it does not support it over the WebOS media player, they forgot to update it or over looked it.

So yeah you need a Shield to play the audio, you can plug the Shield directly into the TV with eARC and it will send the TrueHD 7.1 Atmos and DTS:X to the Q90.

Be aware also the C9 does not support PCM 7.1 over eARC something else LG over looked.
Thanks for the insight. I use plex on LG, which also need to be updated. I can get atmos for 5.1 but not truehd 7.1. I also hit the PCM issue first and was puzzled why I get only 2.0 audio. I changed HDMI output to pass through and changed PCM to bitstream. I hope they fix this in the future firmware updates. The Airplay 2 is buggy as well.
 

Similar threads

Top Bottom