LG HU70LS Projector not sending Dolby Atmos to Samsung Q950A

captaincomedy

Novice Member
Hi, I hope someone here can help me,

I can't get Dolby Atmos out of my projector to my Samsung Q950A, It's connected via the HDMI ARC (There's no E-ARC) and into the arc on my sound bar, however the sound bar just registers as a normal signal and does ZERO surround on it. Only using the surround option can I get my rear speakers to output, which sounds more like an "up mix" than true surround.

I've looked into the sound bar and I have seen reports of people not getting Atmos, but I'm not even getting "Dolby Atmos" registered on my sound bar LED screen, which tells me I'm only sending a standard signal?

On the projector instructions, the only reference to Atmos is here:

1638928208362.png


I've got my projector to passthrough audio, but nothing I try seems to work.... I'm now left thinking whether or not I should just give up and send the sound bar back...
 

razy60

Well-known Member
Where are you getting your video and audio from? Is it going direct into the pj from a player or is it a digital stream from another device?
I'd turn off ARC and try it as is, if your sending every feed direct to the pj then audio to soundbar there is no need for ARC.
 

captaincomedy

Novice Member
I got it "fixed" all sources were to soundbar with video to PJ, but I was fooled by Dolby's video channel as they said their video was a "dolby atmos demo" when in fact it was just stereo.

booted up a netflix atmos movie and it worked as expected.
 

The latest video from AVForums

Panasonic LZ2000, LZ1500 & LZ980 Hands-on Launch Event | No QD-OLED for 2022, new 77-inch for LZ2000
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom