• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

LG HT762TZ - Anyone own one?

bmlsh1

Standard Member
Hi,

Yeah i have recently bought the LG HT762TZ and i must say its very impressive in looks but fairly basic in operation but does the job. The only real problem i have is because its a glossy finish it shows dust, i think every 2-3 days it needs a wipe over but the dust can only really be seen when you're close to it plus i probably need to invest in some decent sort of anti static cleaning product for it rather than the little white cloth that LG provide. Its quite meaty in size, i had a 32" LCD TV and the speakers towered over the TV and didn't look right so i therefore had to get a larger TV (oh well), a 37" compliments it well.

Hope this has helped.

Lee.

:)
 

bmlsh1

Standard Member
Before this i had a Samsung HT-TX35R which was faulty, the menu and setup options are easier and more straight foward on the LG compared with the Samsung, but now with the LG setup so far cannot fault it one bit, the sound quality is very good. :)
 

LaTiNo

Standard Member
I also have the LG
tag.png
LG HT762TZ Home cinema set.

I want to play the sound from the laptop I've connected with HDMI through the cinema set instead of the tv. So i've connected the tv via the optical out to the hc optical in. But I can't seem to get any sound out of it. Do I have to change a setting on the TV itself? Anybody experience with that?
 

igibo

Standard Member
Hi Guys,

I have one of these systems.

The funny thing is that all the bottom speakers on the tallboy speakers dont give any sound and the right speaker on the center channel seems to be dead.

Should it be like this?
If so WHY?

Could you please check your systems.
 

LaTiNo

Standard Member
I also have the LG
tag.png
LG HT762TZ Home cinema set.

I want to play the sound from the laptop I've connected with HDMI through the cinema set instead of the tv. So i've connected the tv via the optical out to the hc optical in. But I can't seem to get any sound out of it. Do I have to change a setting on the TV itself? Anybody experience with that?

Nobody having problems with the AUX opt? :lease:
 

The latest video from AVForums

Guardians of the Galaxy Xmas Special, Strange World, Bones and All, and Cabinet of Dr Caligari in 4K
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom