LG CX HDMI ARC issue

JohnOfK

Standard Member
I’ve got an LG CX and it’s great but I’ve got an annoying issue with sound.
I use a home cinema amp for sound so normally have the inbuilt sound turned off.
I switch the input on the amp as appropriate but, every time I switch it to the TV input, I find I have to go back into the TV menu to switch it back from ‘Internal TV speakers’ to ‘HDMI ARC’ to get sound. It doesn’t seem able to keep HDMI ARC enabled once I stop using the TV input, switch to something else but then come back to it next time.
The amp is a Sony DN1080 but I think this is a TV issue.

Thanks if you can advise.
 

andy1249

Distinguished Member
Ive got kind of the exact reverse , in that mine stays exactly where I put it unless I change it.
So if Im using arc and switch to just TV , arc is still the output and I have to change it to TV speakers , basically it always stays on the last setting

If thats useful to you , This is how I setup my sound on the CX

All Settings -> Connection -> Device Connection Settings
Sound Out to HDMI ARC
All Settings -> Sound -> Additional Settings and turn on eARC.
Under All Settings -> Sound -> Additional Settings -> Digital Sound Out select “Pass Through”
 

JohnOfK

Standard Member
Ive got kind of the exact reverse , in that mine stays exactly where I put it unless I change it.
So if Im using arc and switch to just TV , arc is still the output and I have to change it to TV speakers , basically it always stays on the last setting

If thats useful to you , This is how I setup my sound on the CX

All Settings -> Connection -> Device Connection Settings
Sound Out to HDMI ARC
All Settings -> Sound -> Additional Settings and turn on eARC.
Under All Settings -> Sound -> Additional Settings -> Digital Sound Out select “Pass Through”
Thanks. I’m fairly sure that’s how mine is set actually but I’d need to check.
 

BoUnCiNBeN

Active Member
Its been a problem with the CX since it came out. i still haven't figured a fix for it YET!!.

Its definitely the tv though. i have an LG soundbar and they still wont shake hands properly. if i find a fix ill report back. but don't hold your breath because i've been trying for 12 months lol
 

mouldyolddough

Active Member
I’ve got an LG CX and it’s great but I’ve got an annoying issue with sound.
I use a home cinema amp for sound so normally have the inbuilt sound turned off.
I switch the input on the amp as appropriate but, every time I switch it to the TV input, I find I have to go back into the TV menu to switch it back from ‘Internal TV speakers’ to ‘HDMI ARC’ to get sound. It doesn’t seem able to keep HDMI ARC enabled once I stop using the TV input, switch to something else but then come back to it next time.
The amp is a Sony DN1080 but I think this is a TV issue.

Thanks if you can advise.

I think you have a 1080 issue as I also have that. Well, I gave up on using ARC and route everything through my amp. To be quite honest, the 1080 has been a bag of sh*te with it's issues and I'll never buy another Sony. There is also the "Home" issue that they have been aware of for years and they haven't bothered to fix it.

My C7 and 1080 initially played well together, and then the HDMI-CEC issue happened and the tv would turn itself on at random times whether it was during the night or when I was out at work. I had to switch off the CEC.
 

The latest video from AVForums

Samsung S95B QD-OLED Review - A Quantum Leap for OLED!
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom