LG CX and Onkyo TX-NR636 ARC not working

Sierra76

Novice Member
I'm having trouble setting up ARC. The TV is LG OLED CX, in which I have HDMI ARC and Simplink (HDMI-CEC) enabled, HDMI 4K cable, bandwidth 18mbit connected to HDMI 2 (arc) goes to the Onkyo TX-NR636 receiver to its HDMI Out (arc) output. Simplink is also turned on in the receiver. I don't have anything else connected to the receiver, it has to be only for the ARC. I still have a UPC decoder connected to the TV via hdmi 1. Everything is on and I have no sound via ARC, I tried to configure the magic remote to control this Onkyo, during this procedure I write to test the Power and Audio. Pressing the Power button during the connection procedure will turn the receiver off and on, so it's okay, then the Audio button appears, which I press, and at some point on Onkyo changes the sound source to Direct or sometimes writes Dobly Digital, so I click confirm and it's ready. And it doesn't help either. I do not know what I am doing wrong. I had this Onkyo was connected to the LG OLED C8 2 years ago and everything was ok via ARC, maybe something in Webos has changed recently? I also tried other sources, such as Netflix, YT - zero sound. The speakers are connected to Onkyo properly, I can listen to music via Bluetooth or Opical cable, only this Arc is giving me trouble: / Will someone help? :)
 

basserphil

Active Member
go to "all settings", select sound
sound out setting should read "hdmi sound out".
then open "additional settings"
i have DTVaudio set to "auto"
under "digital sound out"......i have set it to "pass through"
my amp now works atmos arc with the tv

hope this helps?
 

Sierra76

Novice Member
Here's what I tried to do and setup to run ARC on the LG CX with Onkyo 636:

1. LG CX audio output to HDMI ARC.
2. I have LG CX HDMI Ultra Deep Color turned off on all HDMI ports.
3. LG CX Simplink enabled along with device on / off control.
4. LG CX digital audio output set to Pass Through (but I also tried PCM and Auto)
5. LG CX Quick Start+ off
6. LG CX HDMI input signal format all set to bitstream
7. Onkyo 636 HDMI-CEC and ARC turned on (when I turn on [from HDMI CEC off state] it tells me "searching ..." then "not available" and finally "RIHD on" [I think it means no detected a CEC compliant device]) - I also tried to turn it off - exit the menu completely - go back and turn it on again.
8. I disconnected all HDMI cables connected to the LG CX, I also turned off both devices (LG CX and Onkyo) completely and then turned on the TV and connected only Onkyo to it.
9. HDMI 2.0 cable (4K, 18mbit) connected in Oknyo to HDMI Out, and in LG CX to HDMI 2 (with the inscription eARC) [I also tested 2 other cables I have, on all of them ARC worked with Onkyo connected to LG C8 3 years ago)
10. LG CX in Onkyo settings I connected and configured both as home theater and speakers (LG itself detects it at the first connection as speakers)
11. I was restoring both devices to the factory state (hard reset).

Have I missed something?

When I use the optical output from LG CX to Onkyo, I have the sound, but I want HDMI ARC ... I wrote to the supporters of both devices, but somehow I doubt that they will help me.
 

Blackdog 48

Novice Member
Having the same problem with my new LG OLED C1. Hope optical works because I've spent 4 hours yesterday trying to go through the LG settings, did the same steps you did and no luck.
 

Sierra76

Novice Member
Small update:

I got it working now.

How? I don't know, it just started to work today out of sudden! I didn't do anything about it.

I also found out that the ARC gets broken when I connect my PC HDMI cable to LG. When I unplug it, and restart TV, the ARC begins to work again.
 

Normanlai

Novice Member
Having the same problem with my new LG OLED C1. Hope optical works because I've spent 4 hours yesterday trying to go through the LG settings, did the same steps you did and no luck.
Please don't drop back to optical because it stopped supporting standards up to a decade ago. (no DD+, no ARC for sure)

Let me nitpick for some experimentation. Buy a certified 2.1 cable. I was also a victim of blind faith and blind confidence (all my cables also worked years ago)

Other than your AVR and Tele turn off all the fancy hdmi on other devices such as ARC. CEC. Pass through is not a problem.
 

Blackdog 48

Novice Member
Figured it out...My Sony DH-590 worked with my speakers on my Bravia with the HDMI cables, but it was set to "Standard" in the really hard to read menu. After finding the owner's manual online (well my IT working nephew did), there are 2 settings for HDMI ARC...Standard AND Enhanced. When I switched it to Enhanced my HDMI ARC worked with the LG TV and ran the sound to my Speakers. Who knew something that simple would be the problem. In the directions, it says the "Enhanced" setting is for 4k TV/Sound. So I'm guessing all stereo receivers have to have this enabled to use ARC port and HDMI with an LG TV.
 
Last edited:

The latest video from AVForums

AVForums Movies Podcast: Which is the best decade for horror movies?
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom