LG C9 (or Plex client app) DTS issue? (Solved)

DT79

Distinguished Member
Does anyone know if there is a known issue with DTS on the LG C9, an issue with the latest version of the Plex client app for LG, or - and please let it not be this - whether LG have done something to DTS compatibility with the latest firmware update?

I noticed yesterday that DTS was only coming through in stereo when played via Plex on the C9, I’ve ruled out the file, Plex server and the amp (by playing the same file via Plex on the Apple TV). DD also working fine via Plex on the C9. I do have DTS enabled on the C9 Plex client app settings BTW.

Any thoughts welcome. By the way I did try to find the C9 owners thread but couldn’t, so happy for Mods to move this question there if it is still going.

Cheers
Dan
 
Last edited:

steveo67

Active Member
Check the correct audio track is selected whilst the file is playing. I've had plex suddenly start selecting a second audio track for no apparent reason.
Also worth checking the format is set to eARC with CEC on and format set to Bitstream. Even if they are, it's worth giving them a cycle.
 

DT79

Distinguished Member
Check the correct audio track is selected whilst the file is playing. I've had plex suddenly start selecting a second audio track for no apparent reason.
Also worth checking the format is set to eARC with CEC on and format set to Bitstream. Even if they are, it's worth giving them a cycle.
Thanks. It wasn’t set to bitstream, but in my defence a) it used to be and at some point obviously got arbitrarily reset and b) that setting is buried in LG’s demented menu structure/nomenclature so i couldn’t easily see that it was set wrong o_O

It was set to ‘DTV audio setting’-auto (which I took to mean that it would output bitstream as I couldn’t see any other options), but what I didn’t realise/remember was that in the full menu under ‘sound out’ you have sub settings under Optical and HDMI (because you can choose your output in the quick settings menu and those options aren’t presented I therefore didn’t think to click into ‘sound out’ under the full settings menu, given it was already set to my output of choice). When I clicked into it I saw that there is a ‘digital sound out’ sub-setting, which was set to auto, but apparently needs to be set to ‘pass-through’ (still no mentioning bitstream by name!).

Man LG wind me up sometimes :facepalm:
 

The latest video from AVForums

Maverick UK Premiere IMAX Review + Top Gun, Tom Cruise, Tony Scott and 4K + Movie/TV News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom