Quantcast

LG C7 OLED Owners and discussion thread

randomBits

Novice Member
Again thanks, so there does appear to be some differences the decoder chips they use between the USA/NTSC and EU/PAL versions. But after matching the settings as closely as I could to yours many of the my issues seem to have cleared up.

Only issue I'm still having is the magic remote pointer and voice features won't work, even after un-pairing and pairing with the tv. Not sure what to do there, but at least things are workable

But if anyone has the settings for a US model OLED55C7P-U I'd still like to see what can be done if possible to clear up the remote issue.
 

adbailey18

Well-known Member
Again thanks, so there does appear to be some differences the decoder chips they use between the USA/NTSC and EU/PAL versions. But after matching the settings as closely as I could to yours many of the my issues seem to have cleared up.

Only issue I'm still having is the magic remote pointer and voice features won't work, even after un-pairing and pairing with the tv. Not sure what to do there, but at least things are workable

But if anyone has the settings for a US model OLED55C7P-U I'd still like to see what can be done if possible to clear up the remote issue.
You tried asking on avsforum?
 

oscarmadfish

Distinguished Member
my C7 has just done an upgrade , its on auto update . I AM IN SHOCK :D
 

Andrew1472

Distinguished Member
my C7 has just done an upgrade , its on auto update . I AM IN SHOCK :D
That’s simply not possible. Auto updates never work.:rotfl:
There is an update though 05.80.55 which does some really mysterious things.

1. Improvement
1) Add HEVC logo to user guide
2) Fix unknown device toast pop-up issue by Galvanic Corrosion

What on earth is the Galvanic Corrosion all about? Rusty TVs failing their MOTs??:confused:
 

adbailey18

Well-known Member
That update released in February as well
 

k17chy

Distinguished Member
Well my c7 is back with Currys for a second time. Exactly the Same fault as 6 months ago, sound but no picture. Also reminded them of the damage they caused last time they had it. So that's also to fix. Also cant accept it back for 2 weeks due to my shift patterns. Thoroughly pissed off now.
 

avjon

Member
Turned on TV this morning and Disney + prompt appeared. Installed and all working fine.
 

k17chy

Distinguished Member
Currys have [email protected]#$ up again. Tv has come back again (2nd attempt) damaged. New screen was fitted and by the looks of it has been dropped on the top left corner. Over a hour on the phone and because is a "free warranty " they can attempt as many repairs as they like (no replacement or refund) with no time frame. Absolute joke. Never use them again after this.
20200325_132006.jpg
20200325_132018.jpg
20200325_132157.jpg
 
Last edited:

Andrew1472

Distinguished Member
Currys have [email protected]#$ up again. Tv has come back again (2nd attempt) damaged. New screen was fitted and by the looks of it has been dropped on the top left corner. Over a hour on the phone and because is a "free warranty " they can attempt as many repairs as they like (no repalcement or refund) with no time frame. Absolute joke. Never use them again after this.View attachment 1273436View attachment 1273437View attachment 1273438
Words fail me. Muppets!!
 

SeeMoreDigital

Well-known Member
Jeez... That's really poor!
 

k17chy

Distinguished Member
Just had a phone call from the CEO team. They are writing off my set and issuing a voucher. Only snag is I have to wait for the stores opening again which could be a while.
 

Andrew1472

Distinguished Member
Just had a phone call from the CEO team. They are writing off my set and issuing a voucher. Only snag is I have to wait for the stores opening again which could be a while.
Can’t you use the voucher online?
 

adbailey18

Well-known Member
Still a result, whats the value? I'd be happy with a wait! First world problems and all🤣
 

navarro67

Active Member
Having strange behaviour on mine since yesterday - dropped into standby yesterday evening whilst watching, no prompt or warning, just switched off. Now same again this morning and it's probably only been on 30mins. Sky box still running, speakers still playing sound through receiver, exclusively a TV issue. Anybody else experience this before or similar?
 

gamingboy

Well-known Member
Hi all. quick question to make sure I’m it missing anything here. I know it’s been spoken about before (prob many times) but can someone remind the situation regarding playing games in anything other than GAME mode on the TV?

Can I rename other HDMI’s to PC and get full colour etc with the same low input lag as Game mode in Standard, Vivid mode for example?

I’ve been using Game mode since day one but noticed the colours take a hit when in this mode. It a big deal but interested to hear what others have their settings on?

Reason I ask is because I read this last night on rting.c0m...

Update 04/24/2017: Turning on PC mode on any of the picture modes will result in input lag of about 21ms. 1080p outside game mode has been corrected after being re-tested.
Update 08/14/2017: webOS update 3.6 fixed the PC mode HDR issue, so 4:4:4 color can now be properly displayed in HDR content. The 4:4:4 + HDR input lag has been measured as ~21 for both 4k and 1080p, which is no different from the other low input lag measurements.

thanks
Hi All,

Im after the same information and this is the latest post online I can find with reference to it. I tried to do some googling and there is less and less posts in recent months with regards to game mode HDR being dark as its an old topic on the 2017 sets.

Apologies for bringing it up again. I have tried to find the answer without asking (please don’t stone me). I was playing Forza Horizon 4 and it seems to have more in game settings and sliders for HDR game mode and looked really good and I was happy with the HDR game mode on the TV.
Using the same TV settings on Forza 7 it wasn’t so great as the in game HDR options are less and I couldn’t make the Forza 7 logo disappear. So I switched to PC mode and using the Forza 7 HDR sliders it looks okay.
Is PC mode still a viable option?

The other rpost was on reddit

https://www.reddit.com/r/OLED/comments/af2ben/_/edvl19a
With work and other commitments I’ve not really been on the forums, not gaming seem to be getting back into the Xbox again
Thanks for any advice
Thanks for any advice
 

Andrew1472

Distinguished Member
An unexpected issue with the brightness setting.
I noticed a slight glow on a black screen last night. All usable SDR picture modes i.e the two ISFs, Technicolor and cinema have needed it set to 51 from day one.
I have now had to set it back to default of 50. I don’t know if it has drifted over time or was affected by the recent firmware update.
All sorted and no big deal, but I thought I’d mention it in case it’s not just my set.
 

Similar threads

Trending threads

Latest News

Roku launches free Roku Channel in UK
  • By Andy Bassett
  • Published
Philips Android TVs add Disney+ support
  • By Andy Bassett
  • Published
Britbox now available on LG smart TVs
  • By Andy Bassett
  • Published
Virgin Media TV customers get 18 free channels
  • By Andy Bassett
  • Published
AVForums Podcast: 6th April 2020
  • By Phil Hinton
  • Published
Top Bottom