LG C1 surround sound delay to PS5

Shred612

Novice Member
Hi all. I recently bought the following for a new setup:

LG C1
Sonos Beam Gen 2
Sonos Play:1 x2 (for surrounds)

I am running HDMI 2.1 from my PS5 to my TV, and from my Beam to my eARC port on the TV.

Seems to be working so far (as far as I can tell — this is a move from a worse TV, worse soundbar, and no surrounds, so it’s a lot all at once. However, in my PS5, I seem to have options between Linear PCM and Dolby/DTS. When I have it set to Linear PCM, there’s no surround. When I set it to Dolby or DTS, I get great surround, but there’s a just-noticeable-enough-to-be-annoying audio delay. Particularly noticeable with dialogue.

I have tried setting the TV to Pass-Through, I have enabled eARC, I’ve tried both Bitstream and PCM, nothing seems to resolve the issue. I’ve messed around with the PS5 settings too, making sure it’s set to AV Amplifier and 5.1. Kind of at a loss.

I asked on the PS5 Reddit and someone told me the C1s have a problem sending 5.1 to devices via PCM, while Dolby is always going to cause a delay. Is this accurate? Is there a known workaround? I am hoping there is some recourse, because I went relatively hard financially (for me, at least) for this to be a TV problem. If it’s a PS5 problem specifically, that sucks but what can ya do until Sony fixes it, I guess.

Thanks!
 

next010

Distinguished Member
Multi-channel PCM is the lowest latency format and requires eARC for 5.1 or 7.1, regular ARC can only do 2.0 (stereo).

Yes Dolby can lag especially on LG products, differences in the hardware chain as eARC/ARC are not strict standards.

As to why PCM 5.1 is not working that could be a compatibility issue even though the C1 and SBG2 both support PCM 5.1 differences in how it is presented via internal handshake may cause it to not work.
1) make sure the firmware of the C1 is up to date
2) make sure the firmware of the SBG2 is up to date.
3) set TV to following
  • eARC = enabled
  • digital sound output = pass-through
  • HDMI input format = bitstream
4) Set the PS5 to following
  • Sound system = AV amplifier
  • Number of channels = 5.1 (also try 7.1)
  • Sound mode = linear PCM

Unplug the TV and PS5 from power outlet so no standby and both are fully off. This in the hope of clearing any temporary EDID (what TV supports) that may be in use by console.

Turn on TV first and then turn on PS5 and see if PCM 5.1 works.

All of the above are the correct settings, if it still wont work your next best option is to contact Sonos support and see if they can resolve it and live with PCM stereo for now.
 

The latest video from AVForums

Panasonic LZ2000, LZ1500 & LZ980 Hands-on Launch Event | No QD-OLED for 2022, new 77-inch for LZ2000
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom