LG C1 HDMI ARC with PC Issues

Valid

Novice Member
Hello,

Seems like every issue I read is with HDMI ARC on these LG TVs. However, I cannot find one that is specific to my problem. Since I've purchased this TV I've had to mess with the settings to get it to work for a PC to TV to Vizio Sound Bar on HDMI ARC. The device is not eARC and that setting is turned off. Once it works though, I usually don't have to mess with it. Unless there's a TV update, like I just had. Now the strange thing is HDMI ARC functions on my TV box but not the PC, but this is a common problem for myself. Usually, messing with the PC settings (windows 10) will fix this issue, but not this time. I have uninstalled the sound drivers manually, and had them updated through the windows troubleshooter, but still have not had luck. One odd thing I've noticed is that when I turn off the sound bar, the TV switches to speakers, and this ONLY occurs when the PC sound does not work through ARC. I've also turned off and on Simplink to try to get it to maybe recognize the sound. I have disconnected and reconnected hdmi cables at every port and tested at each stage with no success. I've been thinking about just disconnecting my TV so that no further updates are made as this is the only time I have this issue.

Does anyone have any tips for getting this to function properly? Anything would be greatly appreciated.
 

next010

Distinguished Member
First up is that Windows default audio output is PCM audio, with HDMI-ARC this can only be stereo audio.

The only sound driver in use with HDMI-ARC is the sound built into your GPU's HDMI output, so your GPU should be your audio output in Windows not the motherboard audio (e.g. Realtek).

Next is that Windows attempts to read the EDID of the TV (which defines what video/audio modes it supports) however this doesn't always work reliably. Its even possible to override the software EDID that is created from that process.

A firmware update could cause windows to think a new display has been attached and if you have multiple audio devices sometimes it can auto switch to what it thinks is the correct one which isn't.

Settings->sound->related settings->sound control panel
Select your GPU audio output and select properties
Go to Supported Formats tab and check that
max number of channels = 2
bit depth = 16-bit
sample rates = 48Khz

Exit properties and If all of the above is present select configure and set it to stereo, then set it as default.

If that fails download CRU
select extension blocks->edit
under data blocks->audio formats check that LPCM 2 channel is present.
under speaker setup check that only Front Left/Right is selected.

If everything is correct and it still wont play ball check that its Windows and not the hardware.
  • Download ubuntu 21.10 desktop ISO image.
  • Use Balena Etcher to write the image to a USB stick.
  • Boot from the USB stick into ubuntu live mode, configure its audio output to be the HDMI and play anything, you can use the internet via browser.
 

Valid

Novice Member
First up is that Windows default audio output is PCM audio, with HDMI-ARC this can only be stereo audio.

The only sound driver in use with HDMI-ARC is the sound built into your GPU's HDMI output, so your GPU should be your audio output in Windows not the motherboard audio (e.g. Realtek).

Next is that Windows attempts to read the EDID of the TV (which defines what video/audio modes it supports) however this doesn't always work reliably. Its even possible to override the software EDID that is created from that process.

A firmware update could cause windows to think a new display has been attached and if you have multiple audio devices sometimes it can auto switch to what it thinks is the correct one which isn't.

Settings->sound->related settings->sound control panel
Select your GPU audio output and select properties
Go to Supported Formats tab and check that
max number of channels = 2
bit depth = 16-bit
sample rates = 48Khz

Exit properties and If all of the above is present select configure and set it to stereo, then set it as default.

If that fails download CRU
select extension blocks->edit
under data blocks->audio formats check that LPCM 2 channel is present.
under speaker setup check that only Front Left/Right is selected.

If everything is correct and it still wont play ball check that its Windows and not the hardware.
  • Download ubuntu 21.10 desktop ISO image.
  • Use Balena Etcher to write the image to a USB stick.
  • Boot from the USB stick into ubuntu live mode, configure its audio output to be the HDMI and play anything, you can use the internet via browser.

Hello, and thank you for the prompt reply. I have two developments. First, I was unable to find the "related settings" option, and was unable to change any settings to make it function. I noticed that when I changed the display frequency from 120hz to 60hz and turned HDR off the sound would then function again. However, I have a native 120hz display and HDR worked fine before the TV update.

Second, everything now works. I received a prompt to install windows 11 on my device and thought maybe it might fix the sound issue since it was possibly windows related. Updated my pc over about 30 mins and now it functions at 120hz HDR with no issues. Thank you for your assistance, your suggestion it might be windows helped me make the leap to windows 11 (as I was kinda thinking about waiting to update) and now it all functions fine.
 

Valid

Novice Member
Hello again,

Unfortunately, the issue returned just a few hours after posting this. I decided to ensure I was using an HDMI 2.1 cable by ordering one, thus the delay in response. I have found the settings mentioned and have seen that the max channels is 2 bit depth, support is 16 bit and sample rate support is 48Khz. I have also downloaded the app mentioned and ensured LPCM2 is present. However, I cannot see a section for speaker setup to show that only front Left/Right speakers is selected. The LG tv has the input setup to PC, and the NVIDIA GPU HDMI output is correct. To state I have a vizio soundbar that has HDMI ARC with 5.1 surround sound. I also use dolby atmos, even though I believe it is lossy due to ARC and not having eARC. Simplink is on and the TV is set to 120hz. However, if HDR or 120hz, and definitely both are selected, there is no sound from my sound bar.

I am starting to think this update has caused this issue, and there are a number of HDMI ARC issues posed not just here but elsewhere in the past month, some mentioning an update. Originally I believed there must be something with windows as my TV would output 5.1 but no TV box outputs 120hz support, and is definitely not HDR. It is only when 1 or both of these settings are on that sound is lost. Furthermore, my vizio soundbar will display an indicator when dolby atmost sound is detected, which it does not if 120hz or HDR or both are on. I have also reset TV settings which did not fix the issue (and reset input to PC, HDMI ARC, and Simplink). I am completely at a loss, and all due to an update. To reiterate, as soon as I change the display settings to 60hz, and disable HDR, sound will work again without failure.

Any help will be greatly appreciated, I'm starting to feel that my investment in an expensive TV was a mistake as I prefer the highest quality image aka. 4k HDR 120hz, yet I am unable to have this since the update.

Also, to state just in case its helpful. If I "test" the sound in windows, I can see that sound is being recognized, but I do not hear anything, the bar will move up and down during the test, or any other thing that will cause sound to be played in windows. I would also like to state that the CRU program states the frequency is 60hz, any attempt to change it to 120hz shows it in red and does not allow me to continue
 
Last edited:

next010

Distinguished Member
The speaker setup in CRU is under extension blocks->edit->data blocks,

There should be a "speaker setup" entry, if no click on add then select speaker setup, edit it to support front left/right only then ok to exit program and then run restart64 to apply change.


HDMI-ARC on LG can only pass PCM 2.0 (stereo), Dolby 5.1, only PCM is native to windows, using Dolby requires an audio transcoder/upmixer or software that supports it directly like a media player or game.

Turn off the Dolby Atmos virtual effect in windows that is an audio mixer which can interfere with the audio output, at least while trying to narrow the source of the problem.

On the TV in WebOS
Digital sound = PCM
eARC = disabled

PCM is stereo only on LG and will change the display EDID hopefully forcing windows to rescan it, just avoid Dolby for the time being to see if the issue goes away.

Also windows fast start up is known to produce unusual issues with Nvidia and LG displays, turning that off may help as a longshot.
 

Valid

Novice Member
Again, thank you for the quick reply.

I have added the stereo option in CRU and ensured the sound was set to PCM with eARC off. I have also turned off dolby atmos. I do have software for it and it created some amazing sound. It was always quite a large difference in quality when windows would accidentally change to stereo. Though I have turned it off for the purpose of troubleshooting, it would be a shame if I lost this functionality as going back to stereo after experiencing atmos is hard to do lol.

However, after changing these settings the sound continues to not function in 120hz or HDR. I have turned off all devices and turned them back on as I usually would to see if it would then take care of it, but still no dice. I did have some weird success last night after I posted. Nvidia had a driver update so I did a clean install of the Nvidia drivers, which included an audio driver, and it again worked for a little while like the first time. Only turning everything right now have I discovered sound did not function.
 

next010

Distinguished Member
Again, thank you for the quick reply.

I have added the stereo option in CRU and ensured the sound was set to PCM with eARC off. I have also turned off dolby atmos. I do have software for it and it created some amazing sound. It was always quite a large difference in quality when windows would accidentally change to stereo. Though I have turned it off for the purpose of troubleshooting, it would be a shame if I lost this functionality as going back to stereo after experiencing atmos is hard to do lol.

However, after changing these settings the sound continues to not function in 120hz or HDR. I have turned off all devices and turned them back on as I usually would to see if it would then take care of it, but still no dice. I did have some weird success last night after I posted. Nvidia had a driver update so I did a clean install of the Nvidia drivers, which included an audio driver, and it again worked for a little while like the first time. Only turning everything right now have I discovered sound did not function.

Yeah that is strange behaviour, cant think of anything else in trying to correct the problem.

Only remaining suggestions I have are

1) Bypass HDMI-ARC if your soundbar has HDMI input, take one of the other video outputs from your GPU (get Displayport to HDMI) and run that direct into the soundbar, set that output as your default for audio while still keeping the PC video direct into the TV.

You can still use HDMI-ARC for everything else but you will have to manually cycle the soundbar to its HDMI input every time you use the PC.

2) Clean install Windows, erase the drive and hope that it solves whatever has gone wrong inside the OS that is killing the audio in HDR or 120hz mode.
 

reactor

Novice Member
Not PC related, but I'm also not able to get HDMI-CEC and ARC working on my G1. I believe it is a bug in the 03.20.45 update since it was working perfect a week ago (ie. before the lastest update). PS5, Series X, Google TV, Yamaha AVR - no HDMI-CEC and no ARC. I have logged a repair request with LG to have them rollback the firmware since users are not able to do that.
 

The latest video from AVForums

Sony Bravia XR A80J OLED TV Review
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom