• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

LG BD 370 question

RebelKC

Established Member
I bought this player from a friend yesterday, only 3 months old and loving it so far apart from the following issue which I will try and explain clearly .......

My set up is a 32LG5700 tv, sky hd connected to HDMI1 and Blu Ray player to HDMI2.

When I go onto the HDMI2 feed to play a dvd/blu ray disc the play icon comes up but the dvd defaults back to the sky HDMI1 feed. I have to manually put it back on the correct feed to watch the disc. Its annoying the hell out of me! :(

I've tried switching the feeds around but it still happens .... HDMI1 to HDMI2 and so on.

Any ideas? The only time it hasnt happened was when I powered down the Sky box first before playing a disc.
 

paulst10

Distinguished Member
I bought this player from a friend yesterday, only 3 months old and loving it so far apart from the following issue which I will try and explain clearly .......

My set up is a 32LG5700 tv, sky hd connected to HDMI1 and Blu Ray player to HDMI2.

When I go onto the HDMI2 feed to play a dvd/blu ray disc the play icon comes up but the dvd defaults back to the sky HDMI1 feed. I have to manually put it back on the correct feed to watch the disc. Its annoying the hell out of me! :(

I've tried switching the feeds around but it still happens .... HDMI1 to HDMI2 and so on.

Any ideas? The only time it hasnt happened was when I powered down the Sky box first before playing a disc.

Sounds like your screen has an 'auto detect' HDMI input 1, the only way round it is to manually select HDMI 2 or turn off the Sky box :(
 

RebelKC

Established Member
Thanks for your response ...... am trying my Sky feed in HDMI3 (forgot I had one, its on the side of the tv) and it seems to have worked ..... for now!! Have Blu Ray in HDMI1.

If it reoccurs I'll just have to use the Sky box switch off ..... not ideal but it works ...... why is nothing simple :(
 

paulst10

Distinguished Member
Thanks for your response ...... am trying my Sky feed in HDMI3 (forgot I had one, its on the side of the tv) and it seems to have worked ..... for now!! Have Blu Ray in HDMI1.

If it reoccurs I'll just have to use the Sky box switch off ..... not ideal but it works ...... why is nothing simple :(

To save you using the side HDMI, you could always use HDMI 2 for your Sky & HDMI 1 for your Blu-ray, the screen will probably auto detect when the Blu-ray player is switched on and switch to HDMI 1 :smashin:
 

RebelKC

Established Member
I did try that ..... and it tried to default to the HDMI2 feed that the Sky was in when I pressed play ........

I havent got an aerial plugged in so dont think auto hdmi kicks in without that.

I've tried BR in 1 and Sky in 2 ....... its locked in for now.

Seems to be the order I switch things on/off, change feed thats affecting it ..... bloody strange :(
 
Last edited:

The latest video from AVForums

Is 8K TV dead? Philips OLED+907, Pioneer LX505 AVR plus B&W 700 S3 Reviews & Visit + AV/HiFi News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom