LG 50PK-590-ZE, no HDMI ports working

Discussion in 'LG TVs Forum' started by EdGodd, Feb 3, 2014.

  1. EdGodd

    EdGodd
    Novice Member

    Joined:
    Feb 3, 2014
    Messages:
    1
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Can anyone help me?

    All of my TV's HDMI ports have stopped working. They know when something's plugged in but always display "No Signal".

    If I turn the TV off and switch on my LG bluray player, the TV comes on and displays "SimpleConnect, connecting" (or something) but then goes back to "No Signal".

    I've tried 3 HMDI devices on 2 HDMI wires, none successfully display.

    Spoke to LG, the bloke said to try updating from the website as I'm currently on v03.03.04 and the TV doesn't think there's any new version but when I tried from a USB downloaded from their website, the TV said "Copying to memory", "Upgrade in progress 0%" and then just flipped to "Unknown error". Tried this a few times from different USB sticks and using different format (FAT and FAT32, the LG man recommended FAT32).

    I rang LG back and spoke to a lady who effectively said I've done everything correctly and there's nothing she can do.. I asked where I can go from here and she palmed me off onto a repair shop 50miles away.

    Are there any more suggestions or am I going to have to take it apart and replace the board?
     
  2. albsky

    albsky
    Active Member

    Joined:
    Mar 26, 2008
    Messages:
    267
    Products Owned:
    1
    Products Wanted:
    0
    Trophy Points:
    46
    Ratings:
    +149
    I have had the same problem with a Panasonic PZ800 plasma TV.
    DTT was working fine but no input working.
    I was out of warranty, so I tried to resolve it myself.
    After I got a service manual, TV itself told me where to look.
    It was a signal processing IC.
    I ordered one in China(10$ total), and had a friend of mine replace it.
    It was a long shot, but guess what: it started working and it still is one year after.
    The repair shop asked me 400 Euro for board replacement.
     

Share This Page

Loading...