Lg 42lw550t optical connectivity to old AV amp

maximum

Standard Member
Hi I recently got my lg 42lw550t and decided to hook it up to my old (5 yrs old) Sony de6865 amp via an optical lead (no hdmi connections).

If I have the amp set to auto for input signal bu All I get is 2.1 sound.
So my full setup is lg tv, Virginmedia v+ connected via hdmi to tv and the amp connected to tv via optical.

Should I be expecting any true surround sound from the Optical out on the Tv whose sounds originates from the V+ box on HDMI?

The sound isn't to bad actually and I can force the amp to provide 5.1.
 

iaint

Active Member
Hi.
At least with my LG TV, have to turn the TV speakers off in the audio menu before it'll pass DD5.1.
--
Regards, Iain.
 

NEOSJW

Novice Member
maximum said:
Hi I recently got my lg 42lw550t and decided to hook it up to my old (5 yrs old) Sony de6865 amp via an optical lead (no hdmi connections).

If I have the amp set to auto for input signal bu All I get is 2.1 sound.
So my full setup is lg tv, Virginmedia v+ connected via hdmi to tv and the amp connected to tv via optical.

Should I be expecting any true surround sound from the Optical out on the Tv whose sounds originates from the V+ box on HDMI?

The sound isn't to bad actually and I can force the amp to provide 5.1.

Try changing the Digital Audio out setting on the Audio setup menu to Auto. I am sure mine was set to PCM, as soon as it was set to Auto it would pass through the DD signal to the amp (you need to ensure the channel is actually encoded using DD though when you test.

Thanks
Simon
 

maximum

Standard Member
Hi.
At least with my LG TV, have to turn the TV speakers off in the audio menu before it'll pass DD5.1.
--
Regards, Iain.

Cheers, will try this.
I have also set the Audio to Auto from PCM but the amp doesn't play out dd5.1, just pro logic.
 

The latest video from AVForums

Podcast: Large Screen HDR TV or Projector For Home Cinema + Best of the Month
Support AVForums with Patreon

Top Bottom