Quantcast

LG 42LH4000 - turns off after 2 hours

bsb_wideboy

Standard Member
Hi guys, Im sorry if this has been posted anywhere else but I can't seem to find what I'm looking for.

I work for a University where we have serveral older Plasma in our foyer to display notices electronically using OneLan.

Now, we have just recently ordered the above TV on my advice, but this TV has a fundermental floor.

I put the TV into Home mode as Store mode brings up loads of information about the TV.

I set the time to come on at 7.00 in the morning and to go off at 21.00.

Exactly 2 hours into it, it turns itself off. No matter what time I set it to turn on.

I have phoned LG who sent an enginner to replace some parts, even though I told them it wasn't a hardware fault. Anyway - long story short. After a fe more phone calls, they advised me that it was a function on TV and it cant be over written.???

They said I would have to either manually turn the TV on and off myself (without the timer set)

Or to go down to the foyer every morning and press 1 button within the 2 hour window.

I can't believe that this setting can't be over written.

Any help please guys would be much appreciated.

Cheers

Gary
 

bsb_wideboy

Standard Member
Hi Jay, a OneLan box simply displays digital media. Pictures, Powerpoint slides, movies - that sort of thing. The input into the TV is VGA.

Normally I would of thought it was the input, but I have a splitter that splits the signal to another TV round the corner and that one works fine.

It's difinatly a setting with the TV but I just dont know how to get around it.
 

S Bibby

Novice Member
Hi,

This does sound confusing - the LCD TV has a timer but it doesn't stay on? I have a feeling this might be a power-saving feature which has come in to use, perhaps due to the way you are using the set. I know some current models will power-down if no input is detected but there should be an explanation in the manual.
 

danbru

Standard Member
I have the exact situation. I work for my college and ordered a LG 42LH40 for the same purpose.

My setup - the TV displays for a Mac Mini running running a Keynote presentation.
The TV is set to power on in the morning and turn off in the evening.

Page 97 of the user manual explains that the TV turns off after 2 hours if no button is pushed. As already stated it is an automatic setting and I cannot find a way to change it...

I do NOT want to have someone manually turn it on and off each day just because of this!
 

greatwitenorth

Standard Member
Same problem here. Anyone found a solution yet? One strange thing is that the TV turns on automatically then turns off after 2 hours, but when I turn it back on manually (at around 10:00am) it will stay on until the off time at (6:00pm). Does the 2 hour turn off function only happen when the tv is turned on automatically?
 

danbru

Standard Member
Does the 2 hour turn off function only happen when the tv is turned on automatically?
Yes, it only happens when it turns on automatically. If any manual input is made within the two hours, then the auto-shutoff feature is overridden and the TV will stay on.

We have had to completely control the on and off times manually to fix our situation. It is unfortunate that the feature cannot be disabled!
 

grega33

Standard Member
Hi,

I'm having the same problem with LG 37SL8000. However, this behaviour is also written in manuals, so we cannot argue with LG. But anyhow it is a stupid behaviour.

Has anybody got a solution.

I've tried to make PC to automatic power-on and go to standby every day, and on power-on it should switch television, too. But TV remains off even if PC wakes from sleep.
 

ckennedy

Standard Member
We have run into the same issue. We have written an Applescript that is running from a Mac. Every 30 minutes, the Mac presses the enter key in the script....thus keeping it awake until the timer kicks off -- in our case, 6 pm.
 

CBo

Standard Member
This is a real pain of a feature! At least have a option to turn this off if you don't want it! Defeats the point of automated turn off and turn on. I suppose the solution is to have a timer on the power? can't seem to find any auto remote solution.
 

iaint

Active Member
Hi.
Can you not turn this auto-off feature off in the hotel mode setup menu? LG should be able to advise how to do this, but a bit of googling may reveal another method...
--
Regards, Iain.
 

Corbin

Standard Member
Has anyone found a solution to this yet? I am running a Raspberry Pi on a LG 32LD490, the Pi is just accessing a web browser which auto refreshes.. the TV is set to come on at 6:30 AM and at exactly 8:30 it turns off, (but is fine for the rest of the day until 6:30PM when it is due to turn off) - any ideas??
 

gotxi

Novice Member
I had this exact same problem and it was crazy to fix it...

Here are the steps:
1) You need:
- Android smartphone with Infrared
- Android APP "Smart IR Remote Anymote" from google play (paid app) Smart IR Remote - AnyMote - Aplicaciones de Android en Google Play
2) Open app, create a new remote: TV -> LG brand -> "SERVICE REMOTE" type -> press the "use internal android IR device" button.
3) Aim with smartphone infrared emiter to infrared receiver of the TV and press "IN_START" in the virtual remote.
4) It will ask a password, depending on your model could be "0000" or "4123". IT IS VERY IMPORTANT TO TYPE THIS PASSWORD WITH ORIGINAL REMOTE.
4) You will access the LG service hidden menu. Inside that menu, go to "system 1" and change the "2 hours off (On timer)" setting to off.
5) Done.

I hope it helps, there is no much information on internet about how to do it.
 

vincenze

Novice Member
You can get into the service menu using different methods. Check this link:
Access hidden service menus / modes - Openlgtv

The older LG TV accepted pressing on the Menu button on the TV and the Menu button on the remote together for a few seconds.

The newer TV LG LF6000 has a joystick instead of buttons. I had to use a different method.

I used my HP IR Infrared Media Center 5187-5049 Remote Control Transmitter OVU400103-00, which I use to control Kodi. It has an infrared transmitter.

I copied the configuration for lirc.conf from the website above.
Code:
begin remote

  name   LG_SERVICE_MENU
  flags RAW_CODES
  eps            55
  aeps          100

  ptrail        534
  repeat  9145  2222
  gap    40702


      begin raw_codes

          name SERVICE_MENU
             9056    4673     545     591     536     598
              531    1678     551     608     476     638
              557     552     581     612     517     608
              582    1693     543    1706     532     589
              539    1709     480    1732     586    1638
              642    1702     567    1667     495    1741
              516    1686     551    1707     508    1755
              505    1708     574    1638     573    1644
              595    1670     568     655     595     547
              585     513     644     530     587     525
              535     626     573     568     625     507
              612

          name IN_START
             9000    4600     550     600     550     600
              550    1700     550     600     550     600
              550     600     550     600     550     600
              550    1700     550    1700     550     600
              550    1700     550    1700     550    1700
              550    1700     550    1700     550    1700
              550    1700     550     600     550    1700
              550    1700     550    1700     550    1700
              550    1700     550     600     550     600
              550    1700     550     600     550     600
              550     600     550     600     550     600
              550


          name EZ_ADJUST
             9000    4600     550     600     550     600
              550    1700     550     600     550     600
              550     600     550     600     550     600
              550    1700     550    1700     550     600
              550    1700     550    1700     550    1700
              550    1700     550    1700     550    1700
              550    1700     550    1700     550    1700
              550    1700     550    1700     550    1700
              550    1700     550     600     550     600
              550     600     550     600     550     600
              550     600     550     600     550     600
              550
     
          name POWER_ONLY
              9019   4523     552     579     552     579
              552    1709     552     579     552     579
              552     579     552     579     552     579
              552    1709     552    1709     552     579
              552    1709     552    1709     552    1709
              552    1709     552    1709     552     579
              552    1709     552    1709     552    1709
              552    1709     552    1709     552    1709
              552    1709     552    1709     552     579
              552     579     552     579     552     579
              552     579     552     579     552     579
              552   43993    9019    2261     552


      end raw_codes

end remote
The old TV accepted this command with the password 0000 entered on the original remote:
/usr/bin/irsend -d /run/lirc/lircd-lirc0 SEND_START "LG_SERVICE_MENU" "SERVICE_MENU"

The new TV accepted this command with the password 0413:
/usr/bin/irsend -d /run/lirc/lircd-lirc0 SEND_ONCE "LG_SERVICE_MENU" "IN_START"

Then I turned off this setting. It's in different places on different TVs.
2 hours off (On timer)

----------------
But my LG TV lose the time settings if there is no power. There is no battery for the clock. Then they can't automatically turn on and off.

So, I just use my infrared transmitter to turn on and off the old TV. Though, the transmitter is low power and it has to be located right near the infrared receiver on the TV.
 
Last edited:

Sandgroper

Novice Member
I had this exact same problem and it was crazy to fix it...

Here are the steps:
1) You need:
- Android smartphone with Infrared
- Android APP "Smart IR Remote Anymote" from google play (paid app) Smart IR Remote - AnyMote - Aplicaciones de Android en Google Play
2) Open app, create a new remote: TV -> LG brand -> "SERVICE REMOTE" type -> press the "use internal android IR device" button.
3) Aim with smartphone infrared emiter to infrared receiver of the TV and press "IN_START" in the virtual remote.
4) It will ask a password, depending on your model could be "0000" or "4123". IT IS VERY IMPORTANT TO TYPE THIS PASSWORD WITH ORIGINAL REMOTE.
4) You will access the LG service hidden menu. Inside that menu, go to "system 1" and change the "2 hours off (On timer)" setting to off.
5) Done.

I hope it helps, there is no much information on internet about how to do it.
 

Sandgroper

Novice Member
Brilliant!!!!!!
This has been bugging me for a long time. The fix worked exactly as described (except that the passcode was 0413 on my TV).
Well done and thanks gotxi
 

joehayward

Novice Member
My solution to this was to place our TV in hotel mode, but not use any of the settings. To do this:
Hold settings button until the menu appears then disappears and then the TV channel info pops up. Now release the menu button and quickly type 1105 and press 'OK'. Now press the Menu button again. This will bring up the hotel mode menu. Just enable this and your TV will now not automatically turn off. This fix worked for LG 47LB630v
 

scottp1

Novice Member
I had this exact same problem and it was crazy to fix it...

Here are the steps:
1) You need:
- Android smartphone with Infrared
- Android APP "Smart IR Remote Anymote" from google play (paid app) Smart IR Remote - AnyMote - Aplicaciones de Android en Google Play
2) Open app, create a new remote: TV -> LG brand -> "SERVICE REMOTE" type -> press the "use internal android IR device" button.
3) Aim with smartphone infrared emiter to infrared receiver of the TV and press "IN_START" in the virtual remote.
4) It will ask a password, depending on your model could be "0000" or "4123". IT IS VERY IMPORTANT TO TYPE THIS PASSWORD WITH ORIGINAL REMOTE.
4) You will access the LG service hidden menu. Inside that menu, go to "system 1" and change the "2 hours off (On timer)" setting to off.
5) Done.

I hope it helps, there is no much information on internet about how to do it.
THIS WORKED!
It took awhile but I was determined to fix the 2 hour timing off problem.
My 50" LG tv used the code: 0413
But be aware that the Smart IR Remote Anymote app does not work on all Android phones with IR Blaster. Here is list of phones from Anymote website:
........Our app works on any phone or tablet that has an integrated IR Blaster and implements the Android IR Blaster methods. This means that it works on phones:
** like the Galaxy S4, S5, Galaxy Note 3, Note 4, all Galaxy Tabs with an IR Blaster and the HTC One M7 and M8.

** However, LG, Sony, Huawei and Vizio phones or tablets are a few of the offenders, not giving developers like us access to the IR Blaster, when included in their devices.
 

Strider05

Novice Member
I have a OLED55C7V-Z and have tried everything in this thread with no success.
Does anyone have any further suggestions?
Help would be appreciated as SHMBO is not happy with the TV turning off ofter 2hrs!
 

JayCee

Distinguished Member
I have a OLED55C7V-Z and have tried everything in this thread with no success
I'm not surprised as this thread is for much older sets.
Have you read the troubleshooting guide on page 12 of your TV's user manual re sleep timer/Timer power off and Auto power off under the ECO settings menu.
 

Similar threads

Trending threads

Latest News

AVForums Podcast: 17th February 2020
  • By Phil Hinton
  • Published
Samsung faces lawsuit over quantum dot usage
  • By Andy Bassett
  • Published
BBC licence fee to be scrapped?
  • By Andy Bassett
  • Published
Mini LED Active Matrix to boost market uptake
  • By Andy Bassett
  • Published
Bristol Hi-Fi Show 2020 - What to expect
  • By Andy Bassett
  • Published
Top Bottom