Lexicon MC1

Discussion in 'AV Pre-Amp/Processors & Power Amps' started by marck, Jul 15, 2002.

  1. marck

    marck
    Standard Member

    Joined:
    Jul 10, 2002
    Messages:
    602
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    London
    Ratings:
    +1
    Hi,

    I have just bought an MC1 and am very happy with it. However I have a slight problem.

    When I am playing DTS DVD's the Lexicon makes this loud noise - sounds like a fan starting up. When pausing or stopping the DVD you can hear it 'slow down' and stop.

    I am using a Pioneer 626 DVD player.

    Has anyone got any ideas why this is happening and what needs to be done to resolve it.

    Thanks
    Marc.
     
  2. Lowrider

    Lowrider
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I don´t know about the MC1, but the TAG has an option on setup to disable something when detecting DTS, don´t know if it has anything to do with your problem either... :confused:
     
  3. marck

    marck
    Standard Member

    Joined:
    Jul 10, 2002
    Messages:
    602
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    London
    Ratings:
    +1
    I have just spoken to someone from Lexicon and they said it is due to the fan on the DTS processor - they are going to let me know what needs to be done...

    Has anyone else had this problem?
     
  4. Mark Ward

    Mark Ward
    Active Member

    Joined:
    Sep 12, 2001
    Messages:
    1,815
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    41
    Location:
    Kent
    Ratings:
    +18
    I've never noticed this fan on mine, it's obviously very quiet under normal conditions.

    One thing's for sure CSE's servicing & customer services department is second to none.

    My MC-1 had to go back today for a warranteed repair, they couldn't have been more helpful.

    Mark.
     
  5. marck

    marck
    Standard Member

    Joined:
    Jul 10, 2002
    Messages:
    602
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    London
    Ratings:
    +1
    I agree - I found that they were extremely helpful.

    I have also spoken with my dealer who I bought it from - Audio-T in Tumbridge Wells and they are sending it back to CSE to get the fan changed/repaired. I have found them to be very efficient too.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice