Lan speed slower than wireless... Help!

Nokmondoo

Active Member
Evening all, I've just bought a android tv box for the bedroom to which I stream films to xbmc from my Hp microserver.

Very strange - I'm getting 6 mbits from the server to the TV box over Wifi but only 3 mbits when connecting with ethernet.

I've checked thru numerous settings on the nic and the router but can't figure it out. I've tried the box downstairs next to the router with different ethernet and still no speed increase.

Any ideas guys?
 

Prem

Standard Member
Does your android box have a dedicated ethernet (rj45) port or do you have a usb to ethernet adapter. If it is via a usb to ethernet adapter, then it could be due to that. There are lot of cheap usb to ethernet adapters with chipsets known to cap the speed at 7mbps. Try replacing it with a branded one
 

Nokmondoo

Active Member
Does your android box have a dedicated ethernet (rj45) port or do you have a usb to ethernet adapter. If it is via a usb to ethernet adapter, then it could be due to that. There are lot of cheap usb to ethernet adapters with chipsets known to cap the speed at 7mbps. Try replacing it with a branded one

Interesting. Yes it's a usb to ethernet adaptor. I'll try another!
 

Prem

Standard Member
One more thing to add. Even if you have a good USB to Ethernet adapeter, if it doesn't get enough power for operation, the speed would get affected. This can happen if you have too many usb devices connected via the same usb hub. In this case you would need a powered USB hub.
Also make sure all devices connected to the usb hub are USB 2.0 devices. Even if one of the usb device is a 1.1, the hub would then operate in 1.1 mode and that also could affect the speed
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom