Keg Eggs Subwoofer

C

chiwan

Guest
Hi Guys

Just wondering if you could help me on something I've noticed today. I placed my ear against one of the front speakers and noticed a buzzing sound coming from it. Tried the other 4 speakers and all had the strange buzzing sound.

Did a few tests and found that it is the Kef subwoofer that is causing the buzzing. The method of deduction is as follows:

1. Removed the subwoofer cable from amp - no buzz
2. Changed the power cable on sub and connected back to amp - buzz
3. Plugged power cable into totally different socket across the room - buzz
4. Turned off subwoofer at the back with power cable still attached - buzz
5. Pulled power cable out of sub - no buzz

Can anyone point me in the right direction to sort the buzzing out. Is my sub-woofer knackered?

Input level on sub is halfway
Crossover is set to 120
phase is all the way to the right
Connected to amp via 5 m Ixos sub cable via low level input


Cheers
 

Jase

Distinguished Member
Have you tried a different sub cable from the amp? Or rerouting the current cable away from mains leads etc.
 
C

chiwan

Guest
Originally posted by Jase
Have you tried a different sub cable from the amp? Or rerouting the current cable away from mains leads etc.

Yep, changed the subwoofer cable between amp and sub, also moved the sub into the middle of the lounge away from power cables near tv.

Still buzzing from the speakers. The only time the speakers don't buzz is if I pull the power lead out from the subwoofer. Do you think it warrants calling Kef to hear what they have to say?
 

The latest video from AVForums

LG C1 OLED TV Best Picture Settings for SDR, HDR and Dolby Vision
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom