1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

KEF PSW 2010 Sub Fault

Discussion in 'Subwoofers' started by sofasurfer, Sep 11, 2005.

  1. sofasurfer

    sofasurfer
    Active Member

    Joined:
    Dec 16, 2003
    Messages:
    1,451
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    63
    Ratings:
    +101
    Hi there

    Just turned on my system after a week of being away and the sub is buzzing like a road drill.I have checked the connections and they are all fine but nothing seems to work.

    The sub is three years old and it looks as if it is screwed.After reading some of the threads on this forum it looks as if the PSU may have gone.

    Its out of warranty from Sevenoaks but will KEF help me out.If they do it will be a godsend as I am based in Maidstone and so are they

    Any help gratefully received.
     
  2. binbag

    binbag
    Active Member

    Joined:
    Jun 16, 2004
    Messages:
    1,694
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Ratings:
    +81
    KEF have really good CS. Give them a call.
     
  3. sofasurfer

    sofasurfer
    Active Member

    Joined:
    Dec 16, 2003
    Messages:
    1,451
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    63
    Ratings:
    +101
    Thats what I have heard.Just have to wait till tomorrow :mad:

    Would have to happen on a Sunday though
     
  4. stevefish69

    stevefish69
    Well-known Member

    Joined:
    Jun 25, 2004
    Messages:
    4,184
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    106
    Ratings:
    +439
    Have a word with the guys at Sevenoaks, It's a known fault and when mine went down they didn't even ask for the reciept. It was repaired in store and they even lent me their Demo whilst it was being repaired :thumbsup:

    What seems strange is that mine went down imidiately after being switched off for a week. In fact it's the only time that the sub was EVER unplugged from the mains.

    Very Strange indeed :rolleyes:
     

Share This Page

Loading...