Question JVC X3 problem!

Discussion in 'Projectors, Screens & Video Processors' started by creo, Apr 24, 2016.

Tags:
  1. creo

    creo
    Active Member

    Joined:
    Feb 23, 2008
    Messages:
    74
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Location:
    Coventry
    Ratings:
    +7
    Hi all,

    I recently replaced the bulb in my projector (a genuine one I bought from ideal av). The projector was fine for around 20 hours or so. However now when I turn the projector on the standby and warning lights remain lit and the lamp light flashes 3 times.

    I removed the bulb and reinserted it, the projector worked once.

    I tried the old bulb and had the same issue.

    I checked for any debris etc in the bulb insert but there was nothing!

    Where can I get this looked at or does anyone have any suggestions on fixing this issue?
     
  2. creo

    creo
    Active Member

    Joined:
    Feb 23, 2008
    Messages:
    74
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Location:
    Coventry
    Ratings:
    +7
    Hmmm... took the bulb cover off a few times and now I'm getting a projection. WTF. Anyone have any clues what this could be? I reckon the next time I switch it off it'll stop working again...
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice