Jvc tv red blinking standby light problem

dondappa

Novice Member
Hi guys , I bought a used jvc lt40c890 tv and I’m having problems with it , first of all when first plugged in the jvc logo wouldn’t appear on screen and tjen the standby light blink and the tv would turn off after a few seconds , but then if I turned on with the remote it would come on and be fine, this only happened every time I plugged it in, but if I used the remote when it was on standby it would work fine, but then after a couple of hours the tv turned off and wouldn’t come back on, I shined a torch and could see a image so I thought it was a backlight issue so I bought some off eBay and put them in but when I turned on the same blinking standby light and it then turned of after a few second as before , I went into the settings and into a setting called power up mode and that was on standby so I changed it to last state and that seems to have stopped
It turning off after a few secs but the blinking is still there when ever I plug it in it comes on and then blinks 19 times , it still turns on and off correctly with the remote and appears normal in every other way but the 19 time blinking red light when ever I plug it in to the mains has got me worried as i
Suspect this is not normal and don’t want to blow these new backlights if it is a different problem causing it , so at the moment I’m not risking watching it , I’ve tried research img it for hours but can’t seem to find this particular issue , can anyone please give me some advice as to what is causing this or if it normal or how to fix it , many thanks
 

The latest video from AVForums

Maverick UK Premiere IMAX Review + Top Gun, Tom Cruise, Tony Scott and 4K + Movie/TV News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom