• Welcome to AVForums running Xenforo 2.2. The upgrade from 2.1 was successful and finished in just 90 minutes before 8am. The most notable changes in 2.2 are listed in this post.

Question JVC RS48U 3D Not working, Help?

flaperise

Active Member
I Recently Bought a JVC RS48U and it's been working fine, It didn't come with the Emitter or 3D glasses.

Up to a few days ago The Emitter and 3D glasses arrived, Both from JVC shop but for the life of me I can't get the 3D to work.

I've got the 3D cable plugged in tried it both on the PS3 and PS4 and even tried the consoles back on my old X3 to make sure it wasn't the consoles. The Glasses have had a days charged but just doesn't seem to be working?

Could this be anything to do with the fact it's a US import and that I need to buy US Versions of the Emitter and Glasses? Any help Would be grateful,

Thanks
 

iamsludge

Active Member
You might just be needing to entice the PS3 to recognise the projector as a 3d display device.

At first my X3 wasn't recognised so had to make the ps3 go into a wizard setup thing which detected the x3 as a 3d capable device and asked to specify my display image size etc. I think there was a specific sequence of pressing the ps3 on/off button to get into the wizard/setup mode.

The key thing is the ps3 should be asking you what size display. If it doesn't then it doesn't think it's a 3d capable device.
 
Last edited:

The latest video from AVForums

Podcast: Q Acoustics Q3030i, Humax Aura, Roku Streambar & WandaVision Reviews and more...
Top Bottom