Jvc NX7 connection issue with UB 900 DVD player

everytuesday

Standard Member
Hello!
I’m looking for a bit of troubleshooting help + a good cable recommendation for my setup. It seems like either my projector broke, a cable broke or my DVD player broke or a combo of that. Last week this setup was working and now it’s not.

My original setup was DVD player->denon x4500 -> projector with a fiber active cable 75ft

here is what I’ve tested using 2 different cables.

DVD -> old tv non 4K = picture with flickering video/ audio using hdmi 4K cable

DVD (4K cable)> denon x4500 -> old tv using fiber active cable = no picture

Dvd -> old tv using fiber active cable no picture.

dvd-> to projector using fiber active cable = no picture

dvd -> projector using 4K cable non-active = no picture but flickering trying to establish a connection.

Also whenever I’m using the fiber cable, I’m connecting it to the non-arch output on the denon receiver because I can’t get any picture showing up using the arc hdmi. When I use the non-arc hdmi output from the denon I can get a picture with at least my cable box hooked up to the receiver on both the TV and the projector.

Any help is greatly appreciated!
 

Stridsvognen

Well-known Member
Try with a different player and see if that will give you a picture.
 

everytuesday

Standard Member
Hi @Stridsvognen !

thanks for the idea.
I have a Sony x700 that I hooked up to test using the same cables as before and I have some interesting results.

Sony dvd -> projector using fiber active cable works!

Sony dvd (4K cable) -> denon arch output -> projector using fiber active: sound but no picture

Sony dvd (4K cable) -> denon non arc output -> projector using fiber active: sound and picture.

on the back of the denon there are two hdmi options to output I’m sure you are familiar with but I thought I would note that down.

based on this it looks like my arc output on the denon isn’t working properly? Is that required to work between the Panasonic ub900 and the nx7?

also clearly the ub900 is having issues if it can’t hook up just to the projector using the fiber active cable where as the Sony x700 works?

My receiver arc output won’t work, and the ub-900 won’t connect to projector with the active cable…I’m wondering if the arc connection won’t work is that because of the receiver or is that a cable issue?

What do you think?
 
Last edited:

Stridsvognen

Well-known Member
Try if you can default the panasonic player to a 1080P resolution, see if there is a key press option to do a reset, maybe you have forced a 4K 60 that the projector dont like?
 

everytuesday

Standard Member
Try if you can default the panasonic player to a 1080P resolution, see if there is a key press option to do a reset, maybe you have forced a 4K 60 that the projector dont like?
I thought about that too and before I turned it off from the old tv I made sure that 4K was disabled and 1080p was the default. I did also do a factory reset on the player as well.
 
Last edited:

The latest video from AVForums

AVForums Movies Podcast: Streaming Theatrical Releases And The Future Of Cinema
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom