JVC LT-40C880 Netflix won't load and just goes back to source input!


Novice Member
Hi all,

New to the forum so hello and thanks in advance.

My son has a JVC LT-40C880 TV and for some reason the Netflix app won't work.

What happens is if you select it from either the dedicated remote button or from the apps menu, the screen goes black like it's about to load but then simply goes to source input 1 every time, it doesn't ever show the Nexflix logo or come up with an error etc.

I've deactivated Netflix and done a factory reset via the menu many times (they seem to call it installation and is a main menu option?) but it does nothing.

You can't update or delete and re-add the key apps so if it is corrupt, how can I force a re-install, if it's even possible.

All the other apps work fine and I'm struggling to understand how it could be a hardware issue when the app is software and all other apps work? Unless there's some Netflix firmware in stalled that's corrupt as I've noticed a few TVs and consoles etc have a dedicated Netflix system information tab so I'm guessing it's got some heavy duty security and anti-piracy built in.

Any ideas or help would be more than welcome because as it stands I'll be taking the TV back to Currys not JVC no longer make TVs or support their old ones!!!

Many thanks



Distinguished Member
You have to be able to update the app somehow. What OS does the tv run? Can you access the app store?


Distinguished Member
You need to pick the “First Time Installation” option to completely reset that model.


Novice Member
The manual states you can't move or delete the key apps and when you hover over them the menu option (button number 1) greys out and inhibits being selected. This also seemingly means I can't update them . . . ?

That's what I've already done (about 10 times), use the First Time Installation option. Tried different options when setting up but get the same outcome. Maybe I need to select Egyptian for language :D


Distinguished Member
Tried turning it off at the plug for a few minutes(10)?


Novice Member
Ohhhh yes, left it overnight and made no difference.

See the attached pictures for the information given by the TV and the apps screen where you can see it's sat on Netflix but the ability to press number 1 to open the delete/update option is greyed out


  • TV app page.PNG
    TV app page.PNG
    860.4 KB · Views: 27
  • TV settings menu.PNG
    TV settings menu.PNG
    855.7 KB · Views: 26

The latest video from AVForums

Panasonic LZ2000, LZ1500 & LZ980 Hands-on Launch Event | No QD-OLED for 2022, new 77-inch for LZ2000
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom