1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Jvc Gr-dx95u Problem

Discussion in 'Camcorders, Action Cams & Video Editing Forum' started by martyfarty69, Jul 11, 2005.

  1. martyfarty69

    martyfarty69
    Standard Member

    Joined:
    Jul 11, 2005
    Messages:
    23
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    HI

    Hope someone out there can help me, or give me some advice.
    I have a JVC GR-DX95U dv camcorder that i've had for about 2 years, been pretty happy with it overall and had a decent amount of use with it, then all of a sudden about a week ago i turned it on to use it, took the lens cap off, and it was telling me the lens cap was still on.
    Everything else seems fine ( playback etc, snapshot flash and the like !!) but no matter what i try when i put it into record, it's just a black screen and is telling me the lenscap is on.........aaargh
    Any advice, recommendations would be very much appreciated
     
  2. technoman28

    technoman28
    Well-known Member

    Joined:
    Sep 7, 2004
    Messages:
    1,330
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Newcastle upon Tyne
    Ratings:
    +358
    There is a thread running about similar problems with Canon units. (MV600 problems), you may find some pointers there, I also had a thread fairly recently about my JVC camcorder. I was getting error messages, and when I looked into it, found that it was a very common problem. The thread title was "JVC big problem", have a read, and I hope that it does not start to happen with yours. Sorry I cant be of more help.
     
  3. lshiao

    lshiao
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi,

    I have the same model and it's giving me the same problem. Just wondering if you have solved it yet? I've got one guy telling me it's the "ccd ic" which I have no idea what it is! :( Any information would be appreciated!

    Thanks!
     
  4. lshiao

    lshiao
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi,

    I have the same model and it's giving me the same problem. Just wondering if you have solved it yet? I've got one guy telling me it's the "ccd ic" which I have no idea what it is! Any information would be appreciated!

    Thanks!
     
  5. GaryB

    GaryB
    Well-known Member

    Joined:
    Nov 12, 2002
    Messages:
    5,345
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    133
    Location:
    St Albans
    Ratings:
    +1,266
    This is a known problem for which JVC will provide a free fix as long as it was bought from a JVC dealer in the EU and you can provide proof of purchase.

    JVC(UK) have an announcement at:

    http://www.jvc.co.uk/knowledge-list.php?id=4#0

    Most other countries have something similar.
     
  6. Digger004

    Digger004
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I have the same problem with mine. Does anyone know of anyplace in the US or Northern California to get this repaired? And can I still get it repaired without receipt or should I just buy a new one?
    Thanks
     
  7. bazzboy

    bazzboy
    Standard Member

    Joined:
    Jun 8, 2009
    Messages:
    2
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    3
    Location:
    Witham
    Ratings:
    +1
    I can confirm JVC in the UK, will collect & repair, free of charge, the problem where, even with it off, the screen show LENS CAP & then stays black. (CCD image sensor problem).
    I have just called them, 8th June 2009, on 0870-33050002, they have arranged to collect on Friday & repair. I even offered to pay delivery charges, they said that it is a recognised problem & therefore no charges are applicable!!:thumbs up:
    Let you know how it goes.
    Bazza
     
    Last edited: Jun 8, 2009
  8. Billybob27

    Billybob27
    Standard Member

    Joined:
    Jun 30, 2009
    Messages:
    1
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    i have the same problem with my JVC camcorder, when you try to use it it keeps saying "remove lens cover" even though it has been removed, and after contacting JVC with the problem they have arranged to collect & repair my camcorder for FREE:clap::thumbsup:, even though i have had it for 7 years. i think everyone with this problem should contact JVC and see if they can get theirs repaired. I will say that for JVC to repair my camcorder free of charge is great customer service, especially in this day and age.:D:).
    Contact number for JVC customer services is: 087033050002
     
  9. bazzboy

    bazzboy
    Standard Member

    Joined:
    Jun 8, 2009
    Messages:
    2
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    3
    Location:
    Witham
    Ratings:
    +1
    Yup!
    JVC collected, repaired and returned mine within a week.
    It now works perfectly.
    This will definitely make think about JVC first when I want to buy electronics in the future.
    Regards.
    Bazza
     
  10. GaryB

    GaryB
    Well-known Member

    Joined:
    Nov 12, 2002
    Messages:
    5,345
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    133
    Location:
    St Albans
    Ratings:
    +1,266
    That should be 0870 330 5000.
     

Share This Page

Loading...