Question JVC DLA RS10 Fault

Discussion in 'Projectors, Screens & Video Processors' started by Meatfeast23, Jun 17, 2017.

Tags:
  1. Meatfeast23

    Meatfeast23
    Novice Member

    Joined:
    Aug 21, 2016
    Messages:
    3
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    4
    Location:
    Stockport
    Ratings:
    +0
    Hi all

    I have a JVC DLA RS10 Projector which until recently was working perfectly.

    One evening we'd been watching a couple of movies when without warning the projector stopped working, screen retracted (12v Trigger) and the lens cover stayed open.

    I had a few warning lights, standby light went from green to solid red, orange lamp and red warning lights blinking. I disconnected the mains cable and left everything to cool down as the projector had been on for a few hours and thought perhaps it may have overheated.

    When I plugged the mains cable back in the standby light was green but the lens cover remained open and within thirty seconds or so, the warning lights reappeared as described earlier.

    I thought it was the lamp but given that I'd recently bought a genuine new one, I wasn't convinced. My pal has the same projector so he took my lamp and tried it on his, it worked perfectly?

    My concern is that the unit powers up but is completely dead, even the lens cover won't close and I'm concerned it that the lens could end up becoming damaged as it's unprotected.

    The only way I can get the power off is to unplug the mains lead, the power button doesn't appear to do anything at all.

    Any ideas?

    Many thanks.
     
    Last edited: Jun 17, 2017

Share This Page

Loading...