1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Just got some 702e's

Discussion in 'Home Cinema Speakers' started by agw_01, Dec 17, 2002.

  1. agw_01

    agw_01
    Standard Member

    Joined:
    Nov 12, 2002
    Messages:
    169
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    19
    Location:
    Preston, UK
    Ratings:
    +0
    I finally took the plunge and spent my last penny on some new speakers.

    I went to RicherSounds and looked around for a bit, finally deciding that I wanted a pair of Mission 702e's. I firstly asked for some M73s but they do not stock them anymore, and so asked for some 702e's in Beech.

    When I got them back to my dads, he wired them upto his hi-fi (Sony STR-DE405 amplifier) and they sounded crap. No bass, no warm sound, I was totally disappointed.

    When I got them home, I hooked them up straight away to a cheap-ass, distorting TEAC AG-260 recieiver.

    WOOOOOOOO!!!!! :D Major improvment. Ive never heard my house vibrate so much! :D

    These things are fantastic, and you can tell where the bigger cabinets come in. The bass output from these things is amazing. A nice solid bass when playing anything from Will Smith ( :D ) to System of a Down.

    The bad thing is, that this amplifier is crap. It distorts even before it reaches half-volume :eek: so I will have to wait another week until I get my Yamaha DSP-AX620. They sound fantastic on this amp, so I wonder what they will sound like through the Yammy.

    I also bought a Cambridge Audio Atlantic interconnect for my CD-Player. There is a massive improvement in sound quality aswell, so I am going to get a nice bunch of OFC free connectors for my new system.

    Just like to say, thanks to everyone who replied to my other post about choosing speakers. :)

    Have a great christmas (I know I will :D)
    Andrew

    :mad: <<<--- My Mum when I get the Yamaha. lol
     
  2. Nobber22

    Nobber22
    Member

    Joined:
    Jun 6, 2002
    Messages:
    2,977
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Berkshire
    Ratings:
    +109
    Congrats on your new speakers Andrew. Good boxes those 702's. Just don't play 'em too loud until you have run them in a bit at moderate volumes for up to a week. You don't want to damage them. :D

    Bring on that Yamaha!
     
  3. agw_01

    agw_01
    Standard Member

    Joined:
    Nov 12, 2002
    Messages:
    169
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    19
    Location:
    Preston, UK
    Ratings:
    +0
    Thanks Nobber22.

    Errr... too loud? :D On this TEAC! lol

    Yeah, I don't want to damage them, so I will keep the volume low for until I get the Yamaha (in a week, woohoo). When I got the 700's I just ran them for 2 days on moderate volume, while I was staying over at my dads. They have been fine ever since. :)

    Will let you know how I get on.
    Thanks again.

    P.S. Look at my avatar! hehe :p
     
  4. Nobber22

    Nobber22
    Member

    Joined:
    Jun 6, 2002
    Messages:
    2,977
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Berkshire
    Ratings:
    +109
    :cool:
     

Share This Page

Loading...