1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Just bought a Belkin 54g router is it any good ??

Discussion in 'Networking & NAS' started by jamieuk23, Apr 11, 2005.

  1. jamieuk23

    jamieuk23
    Banned

    Joined:
    Oct 25, 2004
    Messages:
    2,159
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    51
    Ratings:
    +27
    Hi I just bought a Belkin 54g router. been using it for the last few days and noticed that the odd time it will loose its connection.

    but 90% of the time the signal strengh is all ways low or very low. and my router is only around 8-10m a way

    I am looking to add my kiss 558 DVd recorder + xbox to this router/network, so I can go online with them.

    Have I bought a decent router that will do the job ??

    + will this router be able to handle the future broadband speeds of 8mb which are comming out during the year ??
     
  2. KraGorn

    KraGorn
    Active Member

    Joined:
    Aug 30, 2003
    Messages:
    4,740
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    68
    Location:
    Warrington
    Ratings:
    +27
    That signal strength seems strange for a 'g' link, what sort of building construction are you in?

    It certainly should be able to connect to an 8mb WAN without any problems.
     
  3. eviljohn2

    eviljohn2
    Well-known Member

    Joined:
    Jul 8, 2002
    Messages:
    7,529
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    86
    Location:
    Near London.
    Ratings:
    +208
    I use a Belkin router and it's very good. Unfortunately the default settings cause it to disconnect from the internet after only a few minutes of no activity so make sure you've changed the "Idle Time" setting to zero.

    May be worth trying it with the "Long Range" protocol to help boost your signal too. :)
     
  4. mrwhippyrulez

    mrwhippyrulez
    Standard Member

    Joined:
    Apr 6, 2005
    Messages:
    16
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Don't have any knowledge specifically of the Belkin, but I would suggest trying a different wireless channel, you may be suffering from interference on the default. Are you using 54G cards in the clients?
     
  5. stripe

    stripe
    Active Member

    Joined:
    Apr 7, 2004
    Messages:
    1,241
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Scotland
    Ratings:
    +123
    I've had one for a while now and I always get an excellent signal strength. Never had any problems with it ad I wouldn't hesitate to recommend one. :thumbsup:
     
  6. dapex

    dapex
    Active Member

    Joined:
    Jul 21, 2003
    Messages:
    1,082
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    38
    Ratings:
    +11
    my signal strength is always low but it works fine
     
  7. gordonfmoore

    gordonfmoore
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Had one for ages. I had the problem you described when I first got it, but used the update firmware option and never had a problem since. Also would recommend it.

    :smashin:
     

Share This Page

Loading...