1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

JS tech rgb->Vga with a PS2?

Discussion in 'Plasma TVs' started by papachumba, Nov 18, 2004.

  1. papachumba

    papachumba
    Standard Member

    Joined:
    Oct 4, 2003
    Messages:
    79
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Just bought one of these JS tech rgb to vga boxes, connected up my SKy, all fine.
    Problem is, when i try and connect my ps2, it gives me a black picture, ocassionaly flashing green/red.

    Why is this? my PS2 is set to output RGB in widescreen, and it is a pal version. :(
     
  2. Davej50

    Davej50
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Aha! Someone else who is having this problem! I have exactly the same thing happening on mine. I've tried changing the PS2 RGB cable, problem still there. I've also changed the JS Master Controller and problem still there.

    However, if I run the RGB cable straight from the PS2 into the JS RGB-> VGA Converter, there is no problem at all!

    It isn't a black screen all the time, just now and again but enough to be annoying.

    I spoke to the guy at JS and he said that maybe I should try to use an official PS2 RGB cable as some of the after-market ones give a 'dirty green' signal or something. But for the life of me I can't find an official PS2 RGB cable anywhere.

    Not too happy about it really as I've spent £50 on the master controller yet I don't even use it because of this problem.
     
  3. papachumba

    papachumba
    Standard Member

    Joined:
    Oct 4, 2003
    Messages:
    79
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    hmmm....
    i tried plugging my one straight into the controller and it doesnt make any difference!

    i am using the official rgb cable that came with the playstation!
    (i have the slimline version)

    has anyone got any suggestions regarding this one?
    i am having to run it into my scart input on the plasma and i really dont wanna do that, there's so much interference (now that i tried my xbox on the component in ntsc, the ps2 signal looks so dirty!)
     
  4. Davej50

    Davej50
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    The plot thickens. So yours is doing it all the time, and I'm only getting it when I use the JS master controller - doesn't make sense does it :(

    I was beginning to think that it was the actual PS2 unit but then surely I would have this problem all the time. Unless it's the scart that goes from the master controller into the VGA converter....might try that when I get home.
     
  5. papachumba

    papachumba
    Standard Member

    Joined:
    Oct 4, 2003
    Messages:
    79
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    nono you misunderstood,
    My PS2 output is absolutely fine if connected straight through to the Scart Plasma input.
    If it is connected through to the JS controlller (in any way - either through the sky box or striaght into the JS controller) there is no picture.
     
  6. Davej50

    Davej50
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Okay, still sounds like we're getting a similar problem though, just in different configurations. Doesn't make things any easier does it.
     
  7. papachumba

    papachumba
    Standard Member

    Joined:
    Oct 4, 2003
    Messages:
    79
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    heh i know what you mean...

    it is definitely the JS controller thats doing this...

    guys i wanna know if anyone on here has their PS2 working through the JS rgb->vga controller?
     
  8. Davej50

    Davej50
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    :) I don't reckon the controller is my problem as it works when plugging directly into it, it's just when I introduce the master commander into the equation that my problems start...

    Any employees of JS Tech on these boards that might be able to help? :lease:
     

Share This Page

Loading...