Joining wired and wireless networks

degeneration

Active Member
My current home computer network set up is as follows:

Desktop PC and laptop connected wirelessly to O2 wireless modem and router.
htpc connected wired to network switch, connected wired to homplugs, connected wired to O2 wireless modem router.

All have windows 7 64 bit installed. All can connected to the internet fine.

I've just installed a NAS and connected it to the O2 wireless modem and router.

this made me aware of a problem with the network. The 2 wirless machines are in the same workgroup/homegroup, can see each other, and as I set up the NAS with the same workgroup name (workgroup) they can also see it.

The wired htpc, also has the workgroup set as workgroup, but it cannot see the homegroup that the wireless machines are on, so cannot see the actual machines. It also cannot see the NAS.

I've connected to the NAS ip address from the htpc, so it can find it, but it doesn't show up anywhere, so I can't map the network drive. Now it is the htpc is the main one that needs to see the nas, but I want the others too as well!!

Why does it seem that the wired and wireless networks are completely seperate, with the exception of the wired NAS, which is showing up to the wireless network?

I want everything to be just one big network! Using the map entire network function, the wireless network doesn't show up on the htpc, and the htpc doesn't show up on the wireless one...

I need help! Please!
 

LJx

Well-known Member
Has it got all the advanced sharing options enabled in network and sharing center
 

degeneration

Active Member
Not tried removing them all from the workgroup. Will try that tomorrow. Having trouble logging in to the router at the moment. What I thought was the login isn't working for some reason...

The htpc has all teh advanced sharing options enabled and passowrd protected sharing turned off.

The switch that I've connected the htpc to (as well as my TV and blu-ray player) should it have dhcp enabled?
My desktop pc is unable to connect to this switch with its assigned ip address, but the htpc can...

Another question, which maybe will require another thread - the NAS is a d-link dns 320. Got it set up in raid 1 with 2x 2tb drives.

I've tried copying files to and from it from the desktop that can see it - it's wireless g connected to the router. While I know that gives a max transfer of 54Mbps, or 6.75MBps, and I'm not likely to get near that, my write speed has been about 450kBps and read speed was about 700kBps which seems ridiculously slow. Anyone got a clue what's wrong there?!



When I get the wired htpc connected, I hope the speeds are going to be better than that, otherwise streaming HD videos is going to be a problem...
 
Last edited:
Do you have any security software on any of your machines ?

Maybe its blocking the connection between each device. I would disable any on one device at a time and see if it can either see the rest or they can see it. After you have done that enable the security and see what happens.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom