1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Jamo DVR50

Discussion in 'Home Cinema Buying & Building' started by dannybrown, Aug 23, 2005.

  1. dannybrown

    dannybrown
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    does anyone know how to factory reset a Jamo Dvr50 system? somehow i've lost picture but still have sound, as the hidden features are controlled on screen i can't see them to change them. Would be grateful of any suggestions.
    Cheers Danny
     
  2. kevH

    kevH
    Active Member

    Joined:
    Oct 11, 2004
    Messages:
    833
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    31
    Location:
    Live Leeds Work Chesterfield
    Ratings:
    +37
    hi danny
    i seem to remember early on my dvr50 froze up and went all a little weird i was advised to download the current firmware from the website and install and ive been trouble free since touch wood.
    i do remember tho that their technical dept ( number on website) were very helpful and got me up an running very quickly if you havent already contacted them just give em a call.
    Hope this helps
    cheers
     
  3. dannybrown

    dannybrown
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    thanks, am waiting for a reply from the distribution centre in the UK which is where i gather they offer tech support from, i have also downloaded the firmware upgrade but can't load it as have no screen to access the menu, thanks for your help anyway, i will persue the tech support people.
     
  4. pannymad

    pannymad
    Member

    Joined:
    May 14, 2004
    Messages:
    11
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    maybe its because you have set component output - I thought I read somewhere that if you set this then you can't see the menus?
     

Share This Page

Loading...