Jamo DMR61 Problems

pcookie

Active Member
Sorry to start a new thread about this unit as I know one already exists, but I need help from all of you, not just owners of this unit.

I finally purchased one of these and hooked it up to my existing set of Elac Cinema 1(MKII) speakers, and several problems have reared their heads.

1). Running through the speaker test, I have to set the sub to almost zero to stop it rattling. When watching a film, everything is okay until a very low bass sequence and then rattle rattle again. I didn't have this problem with my Sony receiver, so is the Jamo faulty?

2). In quiet passages of a film, you can hear a grinding/shuffling sound from the DVD drive as if its hunting for something. Tilting the deck to 45 degrees stops this!

3). On 2 films I've tried - Blade Runner (Box set directors cut) and Close encounters (Box set special Edition) the film seems to pause for a split second every few seconds. On some films, this doesn't happen. In fact, on my older copy of Blade Runner, this doesn't happen at all. Are the discs faulty?

4). Finally, and I've posted this in the remotes section, I get a power on clash with my Humax. If I switch on the Humax, the Jamo powers on as well.

It's such a shame that these problems have arisen, as in every other respect this unit shines. It looks great, Sounds great (apart from the bass) and is well made. I don't want to send it back, but will if I can't sort this out.


cookie
 

RottenFox

Distinguished Member
send it back,and get something else,as i would gather from all the problems that it is faulty,especially with the disc noise/playback problems.
 

pcookie

Active Member
Sorted the bass rattle! Seems my lovely daughter had managed to insert a plastic toy into the front port! Now, just the creaking disc drive to sort out.

cookie
 

The latest video from AVForums

Podcast: Sky Glass, Epson Laser Projectors plus Home Cinema Subwoofers and More…
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom