issues with Sharp BD-HP21H ?

geforce09

Banned
Hi, i recently purchased a new Sharp BD-HP21H blu ray player, connected with a £10 HDMI cable from zavii onto a LG327000 1080p tv,

it plays blu rays flawlessly however i have noticed if i start the player with no disc in the menus work fine , however when i insert a disc and play, the menus (ie, setup screen/play stop info logos etc) become all dislocated/duplicated and geneally look weird and unreadable, as i said before the blu ray itself and the menus within it work fine.

the other unusual thing is the picture mode is set to auto (so should and looks like its outputting in 1080p), however if i go to manual 1080p or 1080i in the settings menu it says 'the connected equiptment is not suitable'...etc)

any help would be appriciated - thank you.:)

 

geforce09

Banned
anyone?? i also noticed all the menus work fine when a SD DVD is played, (only when playing blu ray i have an issue)
and have just played babel and the subtitles wont work, however for everything else they do!!

very confusing but any help would be appriciated
thanks
 

Daftboy

Novice Member
If you have tried the Blu-ray on another TV (If you have one), then it's definatley a fault with the Blu-ray player.
Have you tried connecting up via the composite input just to confirm?
Have you tried re-flashing the firmware on the Blu-ray?

Hope this helps.
 

geforce09

Banned
If you have tried the Blu-ray on another TV (If you have one), then it's definatley a fault with the Blu-ray player.
Have you tried connecting up via the composite input just to confirm?
Have you tried re-flashing the firmware on the Blu-ray?

Hope this helps.
thanks for your reply :) i have tried reflashing the firmware, although it wont let me because 'its identical versions', i have also tried connecting via composite and playing a BD, and everything works fine no problems as do the menus - but it doesnt appear to be HD quality...

could it be something to do with the hdmi cable?

thanks
 

Daftboy

Novice Member
It's a case of elimination:
1. If your set has another HDMI socket, try this, does it work?
2. Do you have another set with HDMI on to test?
3. If you can, get another HDMI cable to test, you can pick up some good, but cheap one's from companies such as CPC.
4. If you can, test the component output (Assume this model has one).

I have the BDHP20 model and I got a similar problem after aprx 30 mins of use.
It was collected for repair (Called the number on the front of the manual) and was back within 5 days.

Try to eliminate the problem so that if your unit appears faulty, you can deal with a repair call, otherwise I imagine they will make you do all these test.

Let us know how you get on:)
 

The latest video from AVForums

Podcast: Reported HDMI 2.1 bugs, Audiolab Amp & LG LED Projector reviews + Best of the Month
Top Bottom