Issue with using LG Magic Remote with LG TV to control Sonos Playbar

Scherif

Member
I just installed the new firmware (3.00.70) on my LG OLED55CXPUA and issue still has not been solved with the Magic Remote and the Sonos Playbar.
 

ifican

Novice Member
Registered just to answer. After searching and driving myself crazy i started looking at everything. Sure enough, on newer software LG moved the device connector under all settings>connection. You then can choose bluetooth/soundbar and then sonos shows up. Just choose optical, if you choose lg optical it won't work and you'll have to redo. Good luck.........
 

eddthened

Novice Member
Registered just to answer. After searching and driving myself crazy i started looking at everything. Sure enough, on newer software LG moved the device connector under all settings>connection. You then can choose bluetooth/soundbar and then sonos shows up. Just choose optical, if you choose lg optical it won't work and you'll have to redo. Good luck.........
Alas no change.
 

eddthened

Novice Member
Do you not have the "connected devices" on the main settings menu under "connection" settings?
Yeah, I’ve added the Sonos as a device. The problem as I understand it is I have the playbase which uses optical to connect so the tv can’t control the volume.

The CX remote disables infrared once the TV is powered on so no instructions from there either which is what the playbase relies on.
 

Noll

Novice Member
Registered just to get into this discussion.

Same problem here etc. Got the 65" CX and still no solution. I'm seriously considering buying a 2019 Magic Remote, which as far as I've read so far does not have the issue. I think the only incompatibility is that you won't be able to use it for the motion controlled cursor. That said, I'd rather give that up until LG fixes the problem than having to use two separate remotes.

Anyone tried this? Still need to doublecheck whether the above is actually the case.
 

ifican

Novice Member
The CX remote disables infrared once the TV is powered on so no instructions from there either which is what the playbase relies on.
The standard magic remote for lg does the same thing, the playbar and base both use optical. I have the playbase connected to this LG and though it was a pain to understand how, once i figured it out it works. The icon on the tv changes to a little + - on the right side when the volume function is working. I wish i would have seen this a few months ago as i could have tested an OLED. Ill do some digging in the mean time and see if i can find anything specific on the cx remote.
 

eddthened

Novice Member
The standard magic remote for lg does the same thing, the playbar and base both use optical. I have the playbase connected to this LG and though it was a pain to understand how, once i figured it out it works. The icon on the tv changes to a little + - on the right side when the volume function is working. I wish i would have seen this a few months ago as i could have tested an OLED. Ill do some digging in the mean time and see if i can find anything specific on the cx remote.
That would be awesome if it can be set up to work with the standard remote! 🤞
 

Noll

Novice Member
Yesterday I received the 2019 Magic Remote and I can confirm the following:
  • Yes, it works with my OLED65CX
  • No, the motion controlled cursor does not work
  • Yes, IR signals are sent when configured through Device Connectors, which also means I can control the volume on my Sonso PlayBar
Apart from the motion cursor not working, there's another downside though: everytime you press the wheel (OK button), it tries to register the remote with the TV, which results in an error message saying the remote is not compatible with the TV. If I can manage to disable this notification, then that for me would be the best workaround until LG fixes the issues.

Anyone know how to disable notification messages in WebOS? :)
 

Ben45

Standard Member
Just purchased 48CX and seem to have the same volume issue as mentioned above using the Magic remote with Playbar. Phoned LG UK customer services and to be frank, the chap didn’t know what I was talking about. He said he will investigate and revert back but I don’t hold much hope. Meanwhile, my sky remote works for volume but is a bit of a faff continually swapping remotes so if anyone knows a work around, please let me know. Thanks
 

GWilliams

Novice Member
I just recently purchased a new 2020 LG tv (65UN7300AUD) and ran into the same frustrations trying to add a Sonos Playbar to the magic remote. After much googling and YouTubing I came upon this thread. I was able to follow the steps to add the sound bar (selecting Sonos as the make) in the TV settings, and then add the remote in the Sonos app, and it worked. Volume up and volume down both worked fine. However, a couple days later I tried to add a pair of Symphonisk surrounds to my Sonos system and now suddenly my volume control with the magic remote no longer works and even after removing the playbar from the LG device list and re-adding it the issue does not resolve. Any advice on what to try? I’m about to pull my hair out with frustration!
 

Noll

Novice Member
Perhaps it only worked when the TV was turnt off? That's how I was misguided into thinking it finally worked. Problem is that when the TV is off, the remote does send out IR signals, but not when the TV is on.
 

GWilliams

Novice Member
Perhaps it only worked when the TV was turnt off? That's how I was misguided into thinking it finally worked. Problem is that when the TV is off, the remote does send out IR signals, but not when the TV is on.
No, after initially getting it set up, it was controlling the tv sound volume (on the playbar) just fine. Apparently I made it further than most people get with this. The bizarre issue is why it suddenly stopped working at all once I added surrounds. I’m baffled.
 

Noll

Novice Member
That's awesome to hear! Can't wait for the firmware to be available here (NL). I think last time I wait for around a week, but feels good to know that it's coming. :D
 

malehumangeek

Standard Member
TV updated to 3.10.20 this morning. Issue with the remote is totally solved.

Not only does the Magic Remote now control the Sonos playbase, it has a nice graphic on the screen indicating volume up and volume down, as opposed to the previous ‘no volume change’ graphic. Very nice.

Well down LG.
 

jmacc

Distinguished Member
I love how LG are very good with fixing issues like this in firmware updates.
:clap:
 

Rich1000

Novice Member
Hi, I’m in Australia. Does anyone know when will get the firmware update? Will it work with the OLED BX as well?
 

DANgerous25

Novice Member
I just received my GX series TV today, the 3.0x firmware exhibits the problem. I updated the firmware to 3.4x using the web form and added Sonos as a device it works perfectly now. So the advice to anyone still experiencing the issue: Update the firmware and add Sonos through the Universal Remote settings -> Optical -> Sonos Playbar. Works right away.
 

andyclark

Active Member
I have an LG LED 65NANO816NA I tried everything I could find and I looked at every forum I think the internet has to offer :)

The easiest solution that will give you days of your life back is to use a standard LG remote.

You lose the functionality of the 'wavy wand' but frankly I didn't like it anyway.

Shame but stops me having to keep getting up and adjust my Sonos PlayBar manually.
 

jmacc

Distinguished Member
I have an LG LED 65NANO816NA I tried everything I could find and I looked at every forum I think the internet has to offer :)

The easiest solution that will give you days of your life back is to use a standard LG remote.

You lose the functionality of the 'wavy wand' but frankly I didn't like it anyway.

Shame but stops me having to keep getting up and adjust my Sonos PlayBar manually.
The wavy pointer is one of LG's top selling points for me :D
 

Smarthome

Novice Member
The standard magic remote for lg does the same thing, the playbar and base both use optical. I have the playbase connected to this LG and though it was a pain to understand how, once i figured it out it works. The icon on the tv changes to a little + - on the right side when the volume function is working. I wish i would have seen this a few months ago as i could have tested an OLED. Ill do some digging in the mean time and see if i can find anything specific on the cx remote.
About our ads
You may also like
So I just bought a CX and was reading this trying to figure out why it wouldn't work on the CX, nothing on here was working. But under the sound setting I changed the digital sound out settings to "pass through" and that changed the volume icon to the +- you mentioned. I then paired the remote through the Sonos app and it worked through all the tests except the mute function. For the record, I have it set to Sonos on the manufacturer setting on the TV.
 

Brianbove

Novice Member
Got it to work thanks to the first reply! Thank you thank you! Turn off LG Soundlink and then go to Sonos app to program remote. BOOM!
 

The latest video from AVForums

Panasonic HZ2000 OLED TV Review: The best OLED for movie viewing in 2020

Latest News

Melco anniversary edition N10 library announced
  • By Andy Bassett
  • Published
What's new on Disney+ UK for November 2020
  • By Andy Bassett
  • Published
Denon, Marantz and Yamaha AV receivers hit by HDMI 2.1 bug
  • By Andy Bassett
  • Published
McIntosh launches MX100 AV processor and MI347 power amp
  • By Andy Bassett
  • Published
Samsung updates and expands access to Samsung TV Plus
  • By Andy Bassett
  • Published
Top Bottom