Question Is this likely to be a Hardware problem?

PerfectBlue97

Active Member
I have a Zotac zbox AD02 running Openelec, and for a while I've been experiencing audio drops.

The sound just stops, and then come back again after a few seconds.

Recently, the screen has gone black for a couple of seconds as well, and the audio has been dropping out more as well. More recently I've been getting a popping noise from my speakers, and some elements of the screen have turned red. Like pure 255,000,000 red. Maybe 5 of 6 times in a 2 hour movie. The dropouts and screen corruption is almost totally random. It happens with both music and video, and at different places each time. It happens with music downloaded from 100% legal DRM free website sites, video from legal DRM free sources, and files that I've made myself using 3 or so different software packages. All of the files play perfectly on my other computers. It also happens with Youtube videos.

Strangely, it usually only starts about 10 minutes into a video. Except for with youtube in which case it could happen randomly.

There is absolutely nothing in any of the Openelec diagnostics (I had other thread open looking for software problems). Nobody on this forum, on the XBMC forum or the Openelec forum could find anything at all in the log files.

So I'm thinking maybe that this is a hardware problem rather than a software one.

The zBox is connected to my Samsung amp via HDMI. I've tried changing the HDMI cable for a much better one, and I've tried different sockets on my amp as well. This is my third media player and it's the only one that has this problem, so I don't think that my AMP is broken.

Wiggling the HDMI cable doesn't seem to cause\resolve the problem.

I've tried booting from a clean SD card and a clean internal HD (Both fresh installs with no plugins). Same problem with both.

Could it be some kind of overheat or memory problem, or a problem on the MB?

If so, what is the best way of finding it given Openelec's limited diagnostic capabilities?
 

next010

Distinguished Member
Could be hardware but on the off chance it is software, linux AMD GPU drivers for older generation hardware are a bit of a mess from my understanding, more recent stuff is much better supported.

Try installing vanilla Ubuntu then Kodi and see if the issue repeats and I've no idea if the driver situation is any better under Ubuntu over Openelec but it's about the most simple thing you can do. You could also try Steam under ubuntu and see if there is any visual corruption on basic 3D games that would be an indicator the GPU is faulty (unless it's fine under Windows in which case it could be driver issues).

I think Openelec has largely fallen out of favor as well, libre-elec is the go to Kodi distro these days, might be worth looking at also
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom