• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

is my microdrive broken?

P

pegleston

Guest
i bought a magistor 2.2gb microdrive 18 months ago which has been brilliant throughout that time and used in my fujifilm s7000 - no problems whatsoever.
yesterday i was transferring a card full with mini video clips to the computer. left it to come back about 45 mins later to discover camera still trying to transfer images (usually does in about 10 mins). it apperared to be stuck on one file for some reason so i cancelled and took the camera off to delete the file and try again.
when i turned the camera back on it said "card is not initialized" in big red frightening letters. have tried to format the card through the camera and windows xp but both say they cannot do it. still giving same message when turning camera on.
have heard various stories about microdrives failing over time and i suspect this is what has happened. does anyone have any advice on how i might check that it is definitely knackered before putting it in the bin and going off to the shops to buy a nice replacement xD card,
many thanks,
paul
 

SeanT

Distinguished Member
I had a magicstor one fail within the first couple of days of using it, now have a genuine Hitachi 6 gig one which has been faultless so far and means I can store all my photos in my camera for ages :)
 

The latest video from AVForums

Fidelity in Motion's David Mackenzie talks about his work on disc encoding & the future of Blu-ray
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom