Is HDCP 2.2 the cuprit?

5to1

Well-known Member
Some screw ups on my part (no trunking) and some bad luck have led me down a bit of a cul de sac with my HDMI distribution.

When we bought our current house I bought a HDMI Matrix (HD) and ran HDMI cables and CAT 6 to all the TV points. All worked well for almost a decade. Then a series of events caused me problems.

1) HDMI Matrix failed
2) I broke the HDMI cable to the main living room TV. So switched to CAT 6 (HD)
3) Bought a 4K TV for the living room
4) Switched CAT 6 extender to 4K 18GBPS (Wyrestorm EX-70-H2)
5) Since all my other TV's are HD, bought a cheap 4K 18GBPS Matrix (variant of XOLORspace 41441) with downscaling. Hoping it would hold me over until HDBaseT 3.0 dropped in price, which would allow me to switch out other TV's for 4K.

Now largely this has got everything up and running. Set to output HD all my sources work. Set to 4K Virgin box is fine as well.

The problem is the Sky Q (2TB) box. At 1080i or 1080p it works without issue. [Sky Q -> Wyrestorm Extender -> TV (FZ952)] - Has worked without issue for months as well. When I add the Matrix:

[Sky Q -> Matrix -> Wyrestorm Extender -> TV (FZ952)]

I run into what I believe are HDCP 2.2 issues.

It largely works (both 8 bit & 10 bit). No sparkles or discernible difference in PQ/SQ. But ~once every hour I get a ~2s drop out (loss of sound and picture). I suspect this is a HDCP renegotiation (does it renegotiate?), either device initiated or due to error.

The cables have been used for months to carry UHD without issue. And the drop outs are occurring so rarely that it surely can't be physical transmission issue.

Moreover, another minor issue makes me believe its HDCP negotiation issue. I run the Sky Q at 1080i normally as it's poor at upscaling compared to the TV. When I switch to 4K it takes so long to show a picture that the 10 second verification timer on the Sky Q box times out. I just see the last second of the timer and then the Sky Q switches back to 1080i as I havent pressed OK to confirm I have a picture. To get over this I just select [Left -> Ok] blind and from there 4K works aside from the aforementioned intermittent loss of picture.

Matrix was bought through Amazon, so I can return it without issue. The seller has responded and said he's happy to take it back and cover return shipping. But I was wondering if it might be worth trying a HDCP 2.2 -> HDCP 1.4 converter first.

The Matrix was only £77 and it will hold me over for now. At some point i'll switch out the other TV's as well, so I'm thinking its better to hold fire for HDBaseT 3.0 to arrive and prices to drop before investing in a better matrix. So if I can get this working and cover me for a couple of years it would suit my needs.

This is all supposition of course, it could the Matrix is defective. But the fact it deals with Virgin V6 without issue, makes me suspect it's a HDCP 2.2 or other interworking issue with Sky Q. I've had a quick look and others on Sky forums have reported issues with Sky Q and HDCP 2.2 (not with this Matrix but with direct connections to TV's & AMPs, etc).

Thanks
 
Last edited:

The latest video from AVForums

AVForums Movies Podcast: Which is the best decade for horror movies?
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom