• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

iPhone restore keeps stopping at exactly the same point

Desmo

Distinguished Member
Any ideas why?

My phone went a bit doolaly yesterday so I decided a complete restore was the best way to go. Tried to restore to 3.1.2, no joy. This morning I've tried 3.1.3 and still no joy. Each time, the progress bar stops at pretty much 2/3 of the way through and stays there. I left it for over an hour this morning and it doesn't budge.

Before I take a trip to my nearest Apple Store, is there anything else to try?
 

sk72

Standard Member
Try and disable your firewall.... My mate had bother trying
to update his iPod touch then he disabled his firewall and it
worked 1st time

Steven
 

Desmo

Distinguished Member
Cheers, will give it a go later :)
 

Desmo

Distinguished Member
Still no joy :(

Also tried restoring on the Mac at work and it gets stuck at exactly the same point.
 

MuzMc

Well-known Member
Desmo- search for some of my posts from last night.

I had a jailbroken 3G and it did the same- what error code is it giving?

Mine was 21, and I finally fixed it by creating a new admin account on my MacBook Pro, and basically fooling the phone into starting again from scratch.

I tried LOADS of things, and that's what finally worked at 2am this morning!

Good luck mate
 

Desmo

Distinguished Member
I'm not getting any error code at all. It just gets stuck and sits there for hours. It's a 3GS that was running 3.1.2 and JB'd. I've tried restoring to 3.1.2 and 3.1.3 on both my Win7 laptop and now the Mac at work. I doubt it's a user account problem as I'm have the same issue on two different machines.
 

TurksMeister

Active Member
I had a similar problem, and it turned out that the USB slots at the front of my PC did not have enough power to complete the process... if you are using the ones at the front, try plugging in to the ones in the back... worked for me.
 

Desmo

Distinguished Member
Thanks for all the suggestions guys, but nothing seems to work. Booked myself in for an appointment. I just can't see it being hardware related having tried it on two different computers and getting exactly the same result.
 

Desmo

Distinguished Member
As far as I'm aware, I've been in DFU every time. The screen is blank and there is no iTunes logo on there. Does iTunes say something different if you're in DFU?
 

hutch

Distinguished Member
If the screen is blank then you are in DFU mode, looks like that appointment is going to be needed im afraid.
 

crocandy

Active Member
If the screen is blank then you are in DFU mode, looks like that appointment is going to be needed im afraid.

Mine basically did the same, although it had an error code of 9 displayed. after my genius bar appointment we both decided my phone was dead. I hope yours is not or if it is you have some kind of insurance
 

Desmo

Distinguished Member
It's still within the initial 12 months warranty so should be fine :)

As long as they don't notice it's been JB'd :D
Should be fine as it doesn't boot at all.
 

Zantos12

Standard Member
My 3Gs did the same as well with no error code. I tried a different usb, firewall off etc on my desktop pc but it kept hanging at the same bit.

I didn't have itunes on my vista laptop so I downloaded it onto that and it restored first time. I then backed it up on my desktop.
 
Any ideas why?

My phone went a bit doolaly yesterday so I decided a complete restore was the best way to go. Tried to restore to 3.1.2, no joy. This morning I've tried 3.1.3 and still no joy. Each time, the progress bar stops at pretty much 2/3 of the way through and stays there. I left it for over an hour this morning and it doesn't budge.

Before I take a trip to my nearest Apple Store, is there anything else to try?

My daughter had this problem last night, so she deleted the download rebooted her pc and started again and it worked. :thumbsup:
 

jlm32

Active Member
when its in dfu mode i think it shows a pic of a lead saying plug in your computer,you need to press the on/off button and home button at the same time,for about 30 or 40 secs then u get the pic i think,
took me about 5 or six times to get it right
 

Desmo

Distinguished Member
My daughter had this problem last night, so she deleted the download rebooted her pc and started again and it worked. :thumbsup:
Well I've tried 3.1.2 that I already had download. I then dowloaded 3.1.3 fresh this morning on Win7 and also 3.1.3 fresh on the Mac. No joy with any of them.

when its in dfu mode i think it shows a pic of a lead saying plug in your computer
Nope, that's the normal restore mode :) With DFU the screen stays blank.
 

istanbul05

Active Member
This happened with my iPhone a week or two ago. I restored using the iPhone 4 firmware, and it work straight away. I must have tried 4 or 5 times with 3.13 before that and it would get stuck about 2/3rds of the way every time. Hope you get it sorted pal. :thumbsup:
 

Desmo

Distinguished Member
I was thinking in trying iOS4 but when I got to download the latest firmware (without redirecting iTunes to cydia) it only offered up 3.1.3 for download. I didn't get the chance to get 4.
 

Desmo

Distinguished Member
Just updated the Mac iTunes to 9.2 and installing iOS4. Wonder what will happen now.
 

Desmo

Distinguished Member
It worked :D

Guess I'll just have to wait for a jailbreak now :(
 

The latest video from AVForums

Fidelity in Motion's David Mackenzie talks about his work on disc encoding & the future of Blu-ray
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom