IP address conflicts showing in router log

RobMcM

Active Member
I wonder if anyone can help me with this. My Huawei 5G CPE Pro router loses its internet connection periodically. Looking in the system log, it seems like each of the outages corresponds with either of these two entries in the log:
  • LAN side maintenance IP address 192.168.11.1 conflict with Device 3a:::d5:**:30
  • LAN side maintenance IP address 192.168.11.1 conflict with Device 82:::a7:**:04
192.168.11.1 is the IP address of the router. Both MAC addresses belong to my wife's mobile phone (an Oppo Find X3 Neo) suggesting that something in the Android configuration is causing an IP conflict in the router.

My first thought was to try fixing an IP address for the phone, but the router only allows me to fix 7 IP addresses and I already have 6 reserved, so can't fix for both possible MAC addresses in the phone.

Do the clever people here think that this conflict would cause the router to roll over, lose its internet connection and need to be restarted, and what, if anything, can I do to solve this?
 

Johnmcl7

Distinguished Member
Duplicate IP addresses can cause major headaches and I'd certainly expect clients to lose internet access if there's two devices with the same gateway IP address. I wouldn't expect it to cause the internet to drop on the WAN side but if the router is going wrong and crashing it seems possible.

I assume the phone is set to DHCP? Are there any entries in your router logs that show which IP addresses it's giving out for DHCP? If it is, I'd have a look at your DHCP scope on the router which should show the range of IP addresses the router can give out, it sounds from what you're saying the router's own address is in that range (say 192.168.11.1 to 192.168.11.100) so it's giving that out to the phone. If that is the case you can simply adjust the DHCP range from 192.168.11.10 to 192.168.11.100 or similar instead but I can't see how the router could have been configured in the first place to give out its own IP address.

Android does allow you to set individual IP address settings for each wireless network so you could set a static IP address on the phone outwith the DHCP scope (say 192.168.11.110 if the settings were as above) but if the phone is getting the 192.168.11.1 from DHCP then if you sort the phone, another device could be given this IP address.
 

RobMcM

Active Member
I assume the phone is set to DHCP? Are there any entries in your router logs that show which IP addresses it's giving out for DHCP? If it is, I'd have a look at your DHCP scope on the router which should show the range of IP addresses the router can give out, it sounds from what you're saying the router's own address is in that range (say 192.168.11.1 to 192.168.11.100) so it's giving that out to the phone. If that is the case you can simply adjust the DHCP range from 192.168.11.10 to 192.168.11.100 or similar instead but I can't see how the router could have been configured in the first place to give out its own IP address.
Thanks, that's super helpful. I certainly haven’t specified an IP address for the phone - I keep the fixed addresses I do have well outside of the DHCP address range to avoid anything like this happening. DHCP range is 192.168.11.100 to 192.168.11.200, while my fixed IPs are 192.168.11.2 to .6. I can't find any other reference to IP addresses in the logs, only the two I posted above - which read to me like the router has been trying to allocate 192.168.11.1 to the phone and to itself, hence the crash. The entries appear multiple times in the log, so it's a repeating issue.

Android does allow you to set individual IP address settings for each wireless network so you could set a static IP address on the phone outwith the DHCP scope (say 192.168.11.110 if the settings were as above) but if the phone is getting the 192.168.11.1 from DHCP then if you sort the phone, another device could be given this IP address.
I did think about trying to do something like this. I did wonder if the phone was set to use a private MAC address - I know my iPhone has a setting for this - which constantly changes, and if I turn this off for this network then I can specify an IP address for the phone and hopefully resolve the conflict... perhaps? Or am I barking up the wrong tree?

It's concerning that the router may continue to try to allocate 192.168.11.1 to another device via DHCP - I have no idea how I could stop this happening given the DHCP range I've already specified in the settings...

The other thing that might be having an influence is that I have a Tenda MW6 Mesh node connected to the router via a LAN port. The mesh device is set in bridge mode, which should disable all DHCP behaviour and make it a slave to the router... but perhaps this isn't working as well as it should and I full reset of that device would help...
 

RobMcM

Active Member
I'm totally distracted from work now and am poking around in the router settings remotely. Oddly, I've seen another device - a Fire TV 4K stick - has been allocated an IP address outside of my specified DHCP range but isn't one of the devices that has a fixed IP. How come this can happen?
 

Johnmcl7

Distinguished Member
It's possible you have two DHCP devices handing out addresses which could cause a conflict, I'd try connecting a PC to the wireless network and check the DHCP server address. Release and renew it a few times and see if you keep getting the router or if it changes to another DHCP server.
 

RobMcM

Active Member
It's possible you have two DHCP devices handing out addresses which could cause a conflict, I'd try connecting a PC to the wireless network and check the DHCP server address. Release and renew it a few times and see if you keep getting the router or if it changes to another DHCP server.
Thanks for all the advice, and sorry to keep asking questions. Where should I check the DHCP server address? Is that in network connection properties on the PC itself? And how will I know if it changes to another DHCP server?

I'm sure these are all quite basic questions but I'm up against the limit of my knowledge here...
 

Johnmcl7

Distinguished Member
Thanks for all the advice, and sorry to keep asking questions. Where should I check the DHCP server address? Is that in network connection properties on the PC itself? And how will I know if it changes to another DHCP server?

I'm sure these are all quite basic questions but I'm up against the limit of my knowledge here...

On the PC open a command prompt (hold windows + R then type cmd then enter) which should bring up an old fashioned looking black window and type the command ipconfig /all then press enter. This will bring up a lot of information so scroll through it and look for your wireless card, it should be the one with the IPV4 address in the range 10.191.11.0. In the same area you'll see an entry for DHCP server and that will tell you the server that gave the PC the Ip address.

If you then type the command ipconfig /release then enter, then ipconfig /renew and enter again it should force the PC to get another IP address from a DHCP server, you can then run ipconfig /all again and see if the DHCP server has changed.

I've come across multiple DHCP servers on networks a few times (usually people plugging in a router to act as a switch so there's two routers and two DHCP servers) and the clients end up randomly changing between the DHCP server each time they request their IP address.
 

mickevh

Distinguished Member
Strictly speaking, routers don't allocate IP addresses to things, it's done by something called a DHCP Server. There's a DHCP Server built in to almost every SOHO "Router" (AKA SmartHub, SuperHub, AIrport, etc.) However "other" things can function as DHCP Servers too - essentially it's a matter of what software they are running.

As others have observed, it sounds like you have multiple DHCP Servers running on your network and the key is to eliminate all but the one one running in your Internet connected router.

In no particular order:

Have you got multiple routers on your network - if so turn off DHCP in all but one of them (see the "Using Two Routers Together" FAQ pinned in this forum for more detail.)

Have you bought some kind of "mesh" or "whole home" Wi-Fi system - if so they may have introduced an additional DHCP Server unless you have configured them correctly.

Have you turned on some form of "Internet Connection Sharing" on anything (like a phone.)

It's not for the feight hearted, but there are protocol analyser tools such as Wireshark that you can use to sniff out this sort of thing - but it is an expert's tool, you'll need to know how to use it, don't just expect to run it up and it says "bing, here's your problem."

Or you could take a tedious and brute force approach. Turn off literally everything, power up your router, then successively turn on everything else one item at a time and see which once breaks the network.
 

oneman

Well-known Member
Have you switch on hotspot on the phone ?

Switch off the router, then from a PC do a IP. Config release and renew. It will show if there is another DHCP server somewhere on your network.
 

RobMcM

Active Member
Thanks for such a detailed response.

Have you got multiple routers on your network - if so turn off DHCP in all but one of them (see the "Using Two Routers Together" FAQ pinned in this forum for more detail.)
No, just the one.

Have you bought some kind of "mesh" or "whole home" Wi-Fi system - if so they may have introduced an additional DHCP Server unless you have configured them correctly.
Yes, I did add a Tenda MW6 mesh system to the house a few months back, and I did wonder if this was causing a problem. I knew that it had to be in 'bridge mode' to leave all the DHCP stuff to my router, but when I first set it up I couldn't get to connect to it to set bridge mode unless it was plugged into the router's LAN port. As soon as I could get into settings I switched the bridge mode on, but it was plugged in and powered on in DHCP mode for a minute or two before I could do this.

I suppose I could try a factory reset of both the router and the Mesh thing and go again, but (a) this removes a whole load of customization (fixed IPs and so on) and (b) perhaps the same thing would happen again... so I'm keen to explore any other options first. But I can't find any settings in either device that seem to show any remnants of the Mesh behaving as a DHCP server...

Have you turned on some form of "Internet Connection Sharing" on anything (like a phone.)
No, all of those are off.

It's not for the feight hearted, but there are protocol analyser tools such as Wireshark that you can use to sniff out this sort of thing - but it is an expert's tool, you'll need to know how to use it, don't just expect to run it up and it says "bing, here's your problem."
Wouldn't know where to start, but I'm willing to give it a go!

Or you could take a tedious and brute force approach. Turn off literally everything, power up your router, then successively turn on everything else one item at a time and see which once breaks the network.
I guess that's the best way. But the internet failures seem to be pretty random, and the only warning in the log is the one I posted originally - which is still happening each and every time the Oppo phone connects to WiFi. But yesterday evening, when I was connecting and reconnecting it quite a lot, the internet connection was completely stable...
 
Last edited:

RobMcM

Active Member
On the PC open a command prompt (hold windows + R then type cmd then enter) which should bring up an old fashioned looking black window and type the command ipconfig /all then press enter. This will bring up a lot of information so scroll through it and look for your wireless card, it should be the one with the IPV4 address in the range 10.191.11.0. In the same area you'll see an entry for DHCP server and that will tell you the server that gave the PC the Ip address.

If you then type the command ipconfig /release then enter, then ipconfig /renew and enter again it should force the PC to get another IP address from a DHCP server, you can then run ipconfig /all again and see if the DHCP server has changed.

I've come across multiple DHCP servers on networks a few times (usually people plugging in a router to act as a switch so there's two routers and two DHCP servers) and the clients end up randomly changing between the DHCP server each time they request their IP address.
Thanks - tried this last night and the laptop I was using picked up 192.168.11.1 (i.e. the correct address) each time from four or five release-renew cycles. But perhaps oneman's tweak (with the main router off) might find something...

As it happens we haven't had an outage since I started this conversation, so maybe the router knows it's in the doghouse and is behaving a bit better now... conflict errors in the log notwithstanding...
 

mickevh

Distinguished Member
I wouldn't bother with a factory reset - it doesn't sound like you need one, it's (ahem) "just" an IP address conflict - albeit a bit of a nasty one as the address that's conflicted is your router's LAN IP address and when that gets compromised, it can affect everything else. Once the conflict is eradicated, everything should work properly.

I thought I might elaborate a bit about what others are saying about using IPCONFIG for context: One of the pieces of information an IPCONFIG /ALL (on a Windows PC) returns is the IP address of the DHCP Server that issued the relevant IP address. Here's an (abridged) example from my laptop...

Connection-specific DNS Suffix . : micknet.local
Description . . . . . . . . . . . : Qualcomm Atheros AR956x Wireless Network Adapter
Physical Address. . . . . . . . . : D0-53-49-E5-FD-1B
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 192.168.1.19(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : 19 January 2022 09:21:21
Lease Expires . . . . . . . . . . : 25 February 2158 17:32:08
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1

Note that the penultimate line cites the "DHCP Server" and an IP address. That IP address is the IP address of the DHCP Server that issue the lease my laptop is using. In most SOHO use cases that will be the (LAN) IP address of your router which wouldnormally also be the "default gateway" (as is the case in my example.)

I rather like @oneman's idea of turning off your main router then doing a IPCONFIG release / renew and see if the DHCP Server address changes which will indicate there's another DHCP Server on your network. If so, thence you can go find it and turn it off. However, note that if a device has a DHCP Lease "in hand" that lease is valid until it expires (in my example, forever,) whether the DHCP Server that issued it is active or not (that's just how DHCP works) so it's not beyond possibility that a client might "revert" to a previous lease it already "owns" despite being told to the relinquish it's lease and go get a new one (which is what release/renew does) - such is the nature of modern OS's which have a kind of "get you on the Internet at all costs" ethos. The issue dates on the leases would be a useful telltale in tracking down such behavour if it manifests.

Finally, for this tome, if you refresh an IP address and get a 169.254.X.Y back, that's "something else" happening. Such addresses are called APIPA addresses and are addresses a client device quite literally "makes up" for itself when it cannot contact a (any) DHCP Server. If that happens (whilst your router is turned off as you test) that would be a good sign that there is not an alternate DHCP Server out there. Once you turn your router back on and release/renew again, the APIPA addresses should disappear and be replaced with a DHCP Lease from your router's DHCP Server.
 
Last edited:

RobMcM

Active Member
Thank you @mickevh, that's so helpful and very much appreciated. I'll definitely give @oneman's suggestion a go and see what the ipconfig /all info reveals.

Yes, I did add a Tenda MW6 mesh system to the house a few months back, and I did wonder if this was causing a problem. I knew that it had to be in 'bridge mode' to leave all the DHCP stuff to my router, but when I first set it up I couldn't get to connect to it to set bridge mode unless it was plugged into the router's LAN port. As soon as I could get into settings I switched the bridge mode on, but it was plugged in and powered on in DHCP mode for a minute or two before I could do this.
(quoting myself, probably bad form)

Do you think that some 'remnant' of the minute or so that my Mesh node was connected to the router and had its own DHCP function switched on could be causing this conflict? And why it is only ever happening with one device? And how can I possibly go about fixing it?

We had another crash and needed to reboot the router again this morning. It is totally possible that the issue is just that the router is rubbish and this conflict isn't anything to do with the drop outs we are experiencing.

Am I worrying about this too much?
 

oneman

Well-known Member
Thank you @mickevh, that's so helpful and very much appreciated. I'll definitely give @oneman's suggestion a go and see what the ipconfig /all info reveals.


(quoting myself, probably bad form)

Do you think that some 'remnant' of the minute or so that my Mesh node was connected to the router and had its own DHCP function switched on could be causing this conflict? And why it is only ever happening with one device? And how can I possibly go about fixing it?

We had another crash and needed to reboot the router again this morning. It is totally possible that the issue is just that the router is rubbish and this conflict isn't anything to do with the drop outs we are experiencing.

Am I worrying about this too much?
It is possible that the lease period hasn't expired, if you look at Mike's example they lease period is 7 days which is pretty common. Most devices actually request to keep the lease at 50% of the period, so after 3 1/2 days the PC will request to keep the address it has been assigned. If the DHCP server is OK with it then the lease clock is reset to 7 days again.

Lease Obtained. . . . . . . . . . : 19 January 2022 09:21:21
Lease Expires . . . . . . . . . . : 25 February 2158 17:32:08


Anyway, assuming that there isn't another DHCP server on your network then your phone thinks it is 192.168.11.1 as a static address which either you assigned to it or some app on the phone (like VPN software) has assigned to itself. In Android you can check if you are using DHCP or static here,

Go to Settings.
Select Network & Internet, then Wi-Fi.
Tap on the network you are currently connected to to open the settings menu.
Select the pencil icon in the top right to access the network settings.
Select Advanced Options.
Check IP Settings, it will show DHCP or static
Check if you are using randomised MAC address (default is not to)

One other thing regarding 'fixed' IP addresses. There are two options to get these,
- Add a reservation on DHCP server to say if it gets a request from a specific MAC address then always give it a specific address. This is the .2 to .6 addresses you mention.
- Manually assign a IP address (and router and DNS details) on the device itself. This bypasses DHCP process altogether. The danger is that you manually an address in the DHCP range so the server will give out that address unaware you have manually assigned it.


One quick though as I type this, when you switch off your router check which WiFi networks are available. Just make sure you don't have an old WiFi network with a remembered WiFi details still active somewhere.
 

mickevh

Distinguished Member
Do you think that some 'remnant' of the minute or so that my Mesh node was connected to the router and had its own DHCP function switched on could be causing this conflict? And why it is only ever happening with one device? And how can I possibly go about fixing it?

Probably not - as @oneman says, leases are typically 24 hours or 7 days, so even if you did have a second DHCP Server active, if it was days/weeks ago, you probably aren't feeling the effects any more.

We had another crash and needed to reboot the router again this morning. It is totally possible that the issue is just that the router is rubbish and this conflict isn't anything to do with the drop outs we are experiencing.

Probably not: Like many the networking processes, DHCP (and IP addressing in general) is a collaborative process between all participants and everything has to "play nice together" for it to work.

Don't be in too big a rush to "blame the router" whenever there is a networking issue. Routers sit on the "edge" of a network connecting you to other networks (which in the SOHO use case means the rest of the world via your ISP,) routers are not sat at the "middle" of a network bossing it. If you didn't need access to the Internet, you could build a perfectly good network without a router at all.

When you do get IP address conflicts, it's much more likely that it's not your router/DHCP Server causing it, it's something else not behaving correctly - usually a "bandit" client device - your phone in this instance.

I had another though recently - if you haven't already done so, set up a DHCP Leases for these two MAC addresses: Device 3a:::d5::30 Device 82:::a7::04 and see if that whips them into line.

Most DHCP Servers will let you allocate a lease manually - usually it's little more effort that picking an otherwise unused IP addresses in the DHCP Scope (range) and ascribing it to the required MAC address. Of course, you need to pay attention that you get the MAC address right.

I would be focusing attention on the phone rather than your router - I'd probably want to go have a look at it and see what IP address it has and how long it's lease length is (if it will show you) - check on the phone itself, not your router. Then I'd tell the phone to "forget" your network, power cycle it, then acquire your network again. And ensure it hasn't got any kind of "personal hotspot" turned on. If it has, that could be the location of an additional DHCP Server. ("Personal hotspots," essentially turn a phone into a router and often DHCP Server also.)
 

RobMcM

Active Member
Thank you. What a fantastically detailed set of responses you guys have given me.

I had another though recently - if you haven't already done so, set up a DHCP Leases for these two MAC addresses: Device 3a:::d5::30 Device 82:::a7::04 and see if that whips them into line.
I have actually already tried this. The phone was set to use a random MAC address, so I turned this off, leaving only the phone’s device MAC, which is one of the two you mentioned, in use. I then went into the router and set an IP reservation for the device MAC, using an address outside of the DHCP range on the router. (Is this what you mean by a DHCP lease? Or is that something else?)

Either way, this didn’t stop the conflict - every time the phone connects the same conflict message appears in the router log. But it doesn’t stop the phone connecting, and the phone ends up with the IP address I have allocated to it and can happily browse the internet.

The only thing I didn’t do was tell the only E to forget the network, power cycle and connect again - that can be tonight’s activity.

Final thought now is that I’m still not sure that the drop outs in connections are anything to do with this conflict - half the time we don’t get a drop out and need a router reboot when the phone connects, at other times we do. It just seemed a bit of a coincidence that there’s a conflict with the router’s own IP address and our internet connection is unstable for other reasons (eg Three being rubbish).
 

mickevh

Distinguished Member
I have actually already tried this. The phone was set to use a random MAC address, so I turned this off, leaving only the phone’s device MAC, which is one of the two you mentioned, in use. I then went into the router and set an IP reservation for the device MAC, using an address outside of the DHCP range on the router. (Is this what you mean by a DHCP lease? Or is that something else?)
Incidentally, do you have any idea why your phone has two MAC addresses - Smartphones usually only have one as most smartphones only have a WiFi NIC.

The DHCP "Scope" is the range of IP Addresses being serviced by your DHCP Server. "Scope" is (I think) the terminology Microsoft use in their DHCP Server, I'm not sure if that's reflected on other platforms. But no matter, I refer to the range of IP addresses you DHCP server is managing. You can usually specify it, even in basic SOHO kit you can often set the start and end address of the range.

A DHCP "Lease" is the name for the thing that the DHCP server gives out which, amongst potentially hundreds of options, often includes the IP Address, lease length (and in SOHO kit) the default gateway and DNS Server addresses which are often your router's LAN IP address.

Some DHCP Servers won't offer out a DHCP Lease (reservation) if it's outside the Scope to you might perhaps try revisiting this and ensure that any DHCP Reservations are within the available scope (and aren't in use by anything else of course.)

Be aware that whenever you set up a DHCP Reservation, it may not come into use straight away. A client that already has another DHCP Lease "in hand" is entitled to keep using it until that lease expires. Only then is the client required give up a lease and solicit a new one. Though, IIRC @oneman mentions a few post back, DHCP Clients normally start requesting a renewal of their exiting lease at 50% of the lease time. Point being, having set up a Reservation, it could be some time before a client device claims it.

Of course, that also points to the fact, if it's not already obvious, that client devices "pull" their DHCP Leases from a DHCP Server, the DHCP Server does not "push" them to the client. Basically it's a four step process -
1) the client says "can I have an IP address" (Discover)
2) any DHCP Servers that hear the "Discover" will send out an offer of a lease (Offer) (if they are so minded.)
3) the client then declares which Offer it wants to accept (Request)
4) the DHCP Server that made the Requested Offer will acknowledge the Request (and any other DHCP Server will then withdraw their Offers.)

Renewal of a lease in hand is similar, but it more or less skips the first two steps. Wiki's article on DHCP is quite good if you really want to get into the weeds.

Either way, this didn’t stop the conflict - every time the phone connects the same conflict message appears in the router log. But it doesn’t stop the phone connecting, and the phone ends up with the IP address I have allocated to it and can happily browse the internet.

The only thing I didn’t do was tell the only E to forget the network, power cycle and connect again - that can be tonight’s activity.

Final thought now is that I’m still not sure that the drop outs in connections are anything to do with this conflict - half the time we don’t get a drop out and need a router reboot when the phone connects, at other times we do. It just seemed a bit of a coincidence that there’s a conflict with the router’s own IP address and our internet connection is unstable for other reasons (eg Three being rubbish).

This is why duplicate IP addresses using your routers IP Address are particularly troublesome. If "something else" starts using your routers (LAN) IP addresses (whether it obtained the IP address through DHCP or any other method) then it effectively knocks out Internet access for everything. It "looks like" the Internet link has gone down, because no-one can get on the Internet, but the link is probably fine and just that no traffic can reach it. And (usually) you won't be able to log in to your router to see what's going on, so you might also think your router has broken, crashed or locked up.

Imagine it like the postal service. Normally, when I and everyone else in my street put our mail in the postbox, a postie comes along and takes it to the local sorting office and off it goes wherever and of course, replies to our correspondence come back the other way. But now imagine something goes wrong and instead of the posties collecting from the postbox, someone else does and takes all the mail off to (lets say) a land fill. Our mail never reaches the sorting office, consequently never gets forwarded anywhere else and of course that means we get no replies. To us, it looks like the sorting office has disappeared, or gone on strike or something. It hasn't - it's still there and working just fine, it just looks broken because our mail is no longer reaching it and our correspondence is not being answerred.

It's pretty much the same in an IP LAN. Every IP device knows something called the "Default Gateway" IP address. Any device that wants to send an IP datagram to a device not connected to "the same" network as itself (it figures this out from it's IP Address and Subnet Mask) sends it to the the Default Gateway and that device then forwards it elsewhere. In a SOHO LAN, the Default Gateway is your router. Thusly, if anything hijacks the router's IP address (deliberately or accidentally) then all the traffic that should be getting sent to your Default Gateway (router) for onward transmission to the Internet gets send to the "bandit" device instead. And who know what happens to it once it's there - it probably just disappears. And, just like my postal metaphor, because no traffic reaches your router, your router isn't sending it to the Internet, and it's not getting any replies. So it looks like "the Internet has gone down." And to rub salt into the wound, the same IP address is also used for your routers admin interface, so you loose connection to that too which looks like the router has "broken."
 
Last edited:

mickevh

Distinguished Member
You might have a look what is going on using ARP (Address Resolution Protocol.)

Ethernet and Wi-Fi LAN's do not transmit IP packets natively (I don't think anything does.) They transmit (respectively) ethernet format packets and Wi-Fi format packets. IP packets are encapsulated inside the relevant lower level ethernet/Wi-Fi packet and are then put on the wires/airwaves by the hardware.

I'll use ethernet for this examplar, but functionally it works pretty much the same way for Wi-Fi.

When host 192.168.1.A wants to send an IP packet to host 192.168.1.Z, it must first find out the MAC Address of host 192.168.1.Z. Host 192.168.1.A will send out a broadcast saying "who is 192.168.1.Z" and if host 192.168.1.Z is awake and listening it will reply saying "I am 192.168.1.Z and my MAC address is 11-22-33-44-55-66" (or whatever it is.) Thence 192.168.1.A can encapsulate it's IP packet inside an ethernet packet and send that ethernet packet to 11-22-33-44-55-66.

This works exactly the same for sending a message to you router 192.168.1.R. ARP will be used to figure out that 192.168.1.R is 00-99-88-77-66-55 (or whatever,) IP is encapsulated in ethernet and sent to 00-99-88-77-66-55. When your router's routing engine receives this, it unwraps the ethernet packet, retrieves the IP packet therein and decides what to do with it next.

When you get a duplicate IP address, this goes wrong because you have two MAC addresses claiming the same IP address and it all gets horribly confused. Often the ARP mapping is pointing the relevant IP address at the "wrong" MAC. And of course, this is why duplicate IP addresses are to be avoided at all costs.

It also might explain why your phone "works" but everything else doesn't (I'd need to be there to be sure.) If you phone has the "correct" ARP IP-MAC addressing, it can still reach your router, but if everything else has ARP IP-MAC addressing that is sending all other traffic to your phone because your phone is screwing it up, then they all fall to pieces.

This is why we are most suspicious that it's your phone causing the problem and not your router. And thusly, it's this phone that's culpable and needs to be "fixed." We're not guarateeing that's the problem, but on the evidence, it looks most likely and why we don't think it's your router or Internet link that's the problem.

If you have a Windows machine you can take look at ARP: Open up a CMD window and run an ARP -a. That will list all the current IP-MAC mappings your Windows machine currently has cached (each IP host maintains it's own ARP cache - they are not shared between hosts.) This cache is only retained for a few minutes, so you need to refresh it quite often. Look for your routers IP address, note it's MAC and whether it is correct (some SOHO routers will tell you the MAC of their LAN itnerface, some don't.) Then see if it changes when you power up the "bandit" phone - you need to generate traffic to cause ARP to do it's thing, so I'd have a second CMD open and send out some pings of your router (anything will do, but ping is fine.) Then monitor the ARP cache for a while and see if the router's IP-MAC mapping is changing.
 
Last edited:

oneman

Well-known Member
Incidentally, do you have any idea why your phone has two MAC addresses - Smartphones usually only have one as most smartphones only have a WiFi NIC.

"
There are usually two MAC addresses, one for wireless, one for Bluetooth but not sure why both are showing up as wireless connections
 

RobMcM

Active Member
Resurrecting this thread just to say that I don’t want to speak too soon but I wonder if I’ve fixed the problem I've been having…

I had another drop out this evening. Before restarting as usual, I had a look at the router in the AI Life app. It said “Ethernet disconnected”. I wondered if this was because my passive LAN switch was plugged into the WAN/LAN port of the router. I unplugged that cable and the app flashed up a red error that I didn’t quite see - possibly WAN port error - then immediately reconnected to the 5G internet at full speed. I have now connected the switch through the LAN port on the Tenda node near the router, and everything is running fine.

Is it possible that a brief internet drop out (caused by my house being on the edge of the Three 5G cell network) causes the router to try and find an internet connection through the ethernet cable connected to its WAN port. When it can’t it falls over, so I need to reboot. I also wonder if this might explain the IP conflict errors - might one device connected to the mesh know that the gateway address is 192.168.11.1 but the router is looking to the mesh for the internet connection.

I suspect that the culprit was this setting in the 'Internet Settings' page of the router config:
1644421305715.png


...and I imagine that setting it to "LAN only" would solve it... but while everything seems to be running fine with the config as above it doesn't seem sensible to change anything else at the moment. I'm also a little scared confused whether this setting is determining where the router will get its internet connection from; i.e. will setting it to 'LAN only' cause the router to (a) only use the ethernet ports as LAN not WAN (this is what I want) or (b) disable the 5G internet connection and tell the router to only look to the LAN ports for its internet connection (this would be bad)?
 

mickevh

Distinguished Member
It's highly unlikely. The IP addressing on the subnets "upstream" of your router (ie through it's WAN 5G interfaces) and the IP addressing on the subnets "downstream" of your router (ie through the LAN ports and Wi-Fi) are unrelated to each other. A change of IP addressing and/or routes out through the WAN/5G interfaces has no effect on the IP addressing on your LAN. Though if that change didn't work correctly, it could kill your Internet access, but that's an entirely unrelated thing to an IP address conflict on your LAN.

Don't change your Internet Settings if they are working - again this it unrelated to any IP address conflicts on your LAN.

I'm not sure what you mean by "I wondered if this was because my passive LAN switch was plugged into the WAN/LAN port of the router." - have you got infrastructure connected to your router's WAN port...? Maybe post up a diagram - it doesn't need to be pretty.
 

The latest video from AVForums

Maverick UK Premiere IMAX Review + Top Gun, Tom Cruise, Tony Scott and 4K + Movie/TV News
Subscribe to our YouTube channel

Latest News

dCS announces Bartók 2.0 firmware upgrade
  • By Ian Collen
  • Published
Audiovector unveils QR 7 loudspeaker
  • By Ian Collen
  • Published
What's new on UK streaming services for June 2022
  • By Andy Bassett
  • Published
LG UltraGear Gaming Monitors get VESA certification
  • By Ian Collen
  • Published
Sony confirms UK pricing for A90K and A75K Bravia XR 4K OLED TVs
  • By Ian Collen
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom