Installing Rel Storm III with Arcam 10

Discussion in 'Subwoofers' started by spear54, Jun 21, 2002.

Tags:
  1. spear54

    spear54
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I have finally taken delivery of my Rel Storm III - its taken me five years to build up a full Dolby 5.1 system but its here.......almost.

    The Rel is an ex-demo model so didn't come with a manual.

    I know that I have to put the Neutrik Speakon cable into the high level output. On the other end of this wire, are three termiantion points (yellow, red, and black) which go into the speaker points. Presumably, two of these wires need to go into one of the speaker points and the third goes into the other? I'd be really grateful if someone could tell me which goes into the red terminal and which goes into the black on my Arcam 10.

    I also have a Yamaha DSP E-800 surround sound amp which powers my centre and rears. I've been told that a phono jack should be used to connect the Yamaha to the subwoofer, but as it has a red and black inputs, I'd be grateful for advice on which to put it into.

    Thank you in advance to anyone who can help.
     
  2. Ian J

    Ian J
    Banned

    Joined:
    Aug 6, 2001
    Messages:
    25,628
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Ratings:
    +4,906
    Eric at REL is very helpful as I had a number of problems when I bought my Storm (also without manual) and amongst other things he emailed me a manual. He can be contacted by email on [email protected].

    If you don't want to wait until next week, PM me your email address and I will forward you a copy of mine
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice