Incorrect Power lead For The UK!

oldfart

Active Member
I do not know if anybody else has this problem, but in the last couple of years whenever I buy any electronics shipped into the UK I get the wrong power lead supplied in the box?. Firstly let me say these items where ordered from UK retail sites and not direct. The last episode was 3 weeks ago when I ordered an expensive DAC made in the USA, I had to wait a few days longer as it was shipped from the UK distributor to the retailer then onto me. Opened the box and low and behold the wrong lead, then had to wait another day while the retailer shipped out the correct lead. Eagerly plugged the DAC into the mains and Nothing, no lights showing on the control panelo_O. Checked the voltage selector underneath what did I see, it was set at 115v:facepalm:. reset to 230v but I knew by then the damage was done. returned it back for a full refund but before I did photographed the box to show it was supplied set at 230v. Considering the cost of the DAC you would have thought before the distributor despatched the item they would have double checked the selected voltage as it was shipped in from the USA. Since this happened have promised myself to buy products made in the UK however that is easier said than done!.
 

mjn

Distinguished Member
PC power supplies often have a switch for 115/230v so i’m used to checking the voltage switch before powering stuff up :smashin:
 

Tempest

Member
Sorry I can't help, but what I can say if this has never happened to me.
I have had items with the little switch on the back, and it's always been set right.
And when ti comes to actual power leads, I have often gotten a US plug/lead in the box, but there has always been a UK one on there also.
Perhaps you've just been unlucky? :(
 

DIYlady

Distinguished Member
I think this is becoming more common. We recently bought two robot vacuum cleaners (same model, different suppliers) via Amazon (uk website). One came with European lead only, this is I believe illegal. The other had a uk lead as a separate item attached to outside of box - legal, but annoying as the original appliance and European lead were white and the “add-on” black. Not a major issue they were only std figure of 8 leads and we have plenty of spares, but definitely irritating
 

ssbib

Distinguished Member
This has happened to me and my family recently too. I bought a hard disc drive that had a EU plug on it and my mum bought a stand mixer that had an Australian plug on it. Both bought from UK retailers. The stand mixer isn’t even available to be shipped to Australia from that company so that one really confused us.
 

ashenfie

Well-known Member
To be honest I've not seen a power supply for a long time that didn't auto switch. I would report them to trading standards as they break the law.
 

nvingo

Distinguished Member
I think it was Ipads that came, with the US-USB power supply in the packaging and the UK 3-pin which clicks on replacing the fitted US 2-pin in the parcel.
Similar with other computing equipment (HDD, NAS) though inside the manufacturer box.
 

nheather

Distinguished Member
One came with European lead only, this is I believe illegal.

Yes it is, though I believe they can get away with providing an adapter.

It’s never really been a problem. Rare to see electrical items that don’t auto-switch. I’ve had a very small number of items with a voltage selector but these have always been preset to 230 VAC. I have some items from China that have come with a US or European plug with a ropey looking adaptor. In these cases if I don’t have a UK equivalent in the spares box I simply cut the lead and fit a UK plug.

OP - in your case, sounds like a packing error, equipment intended for the US market got packed in a UK box.

Cheers,

Nigel
 

The latest video from AVForums

Podcast: Panasonic JZ2000 Final Thoughts - TV Calibration: Should you? And More...
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom