iFi Zen Air Audio Drop Out / Delay

kmn140

Novice Member
Hi, I bought a Zen Air DAC a week ago and have encountered the exact same issue as described in the first post (latest firmware and drivers). Can easily be replicated in Windows by pressing the "Test" button in the device properties window of the sound control panel, or continuously double clicking on a playlist item in a media player such as foobar2k.

This issue can also be easily replicated by using the DAC with a PS4/PS5 console, just navigate around the main menu and most menu beep sounds will either be unplayed or have the beginning cut off.

Reported this issue to iFi support, they say it's a known problem so hopefully it can be fixed as it's a pretty severe issue.

And yes, also had an issue with a very tight USB cable (or socket), had to really pull the cable with force to remove it from the DAC. Recommend using a different cable.
 

iFi audio

Member
AVForums Sponsor
Hi, I bought a Zen Air DAC a week ago and have encountered the exact same issue as described in the first post (latest firmware and drivers). Can easily be replicated in Windows by pressing the "Test" button in the device properties window of the sound control panel, or continuously double clicking on a playlist item in a media player such as foobar2k.

This issue can also be easily replicated by using the DAC with a PS4/PS5 console, just navigate around the main menu and most menu beep sounds will either be unplayed or have the beginning cut off.

Reported this issue to iFi support, they say it's a known problem so hopefully it can be fixed as it's a pretty severe issue.

And yes, also had an issue with a very tight USB cable (or socket), had to really pull the cable with force to remove it from the DAC. Recommend using a different cable.
Thank you for your feedback. Everything posted here is going to the ears in RnD.
I have tried that on my unit, but still nothing. Works as intended. I would happily give you the working one...
Yes, we are aware of the issue thanks to people here and customer support tickets. We are doing our best to fix it as fast as possible.
I have made another internal ticket for USB sockets.
 

kmn140

Novice Member
Good to hear it's being worked on. I actually bought the Air DAC specifically for console use, since iFi DACs are some of only a few that meet PS4/PS5 compatibility requirements (UAC1 support, and bypassing of the host volume setting), with the additional benefit of being able to run bus-powered. Although not pushed so much in the advertising, I think console compatibility is a great plus in differentiating iFi products.
 

iFi audio

Member
AVForums Sponsor
Good to hear it's being worked on. I actually bought the Air DAC specifically for console use, since iFi DACs are some of only a few that meet PS4/PS5 compatibility requirements (UAC1 support, and bypassing of the host volume setting), with the additional benefit of being able to run bus-powered. Although not pushed so much in the advertising, I think console compatibility is a great plus in differentiating iFi products.
Thank you for pointing it out, it's an important feature. Some of us are gamers, so it was important to include that.
 

ZeroGott

Novice Member
It is a faulty socket, I'm sure Amazon will be on your side with this one, even if the dealer decides not to (which he shouldn't).

On the topic of the issue. Air DAC I have gotten works perfectly with v5.12 USB driver and v7.40 firmware. I wasn't able to replicate the issue with my Win10 PC. I have tried youtube in the browser and with the Tidal app. I'm afraid that we still have to wait for RnD to come up with a fix.
1652196651419.png


1652196699186.png


Sorry to say that.
But that cable is actually hot garbage. I tried removing it again cause it doesnt fit into the package otherwise and not the metal cap ripped apart, i can still wiggle the cap inside the socket but its still stuck in there. :rotfl:


But on the serious note.
For everyone that is reading the thread. Dont try to use the cable that comes with the unit atm.
Im trying to send it back and on saturday and i will see what the seller says about it.


€:
Got a response for my Amazon seller.
They are aware of the Issue with the USB cables and are testing every USB Cable now before sending out the Units.
I will get my Money back.
 
Last edited:

iFi audio

Member
AVForums Sponsor
View attachment 1694874

View attachment 1694875

Sorry to say that.
But that cable is actually hot garbage. I tried removing it again cause it doesnt fit into the package otherwise and not the metal cap ripped apart, i can still wiggle the cap inside the socket but its still stuck in there. :rotfl:


But on the serious note.
For everyone that is reading the thread. Dont try to use the cable that comes with the unit atm.
Im trying to send it back and on saturday and i will see what the seller says about it.


€:
Got a response for my Amazon seller.
They are aware of the Issue with the USB cables and are testing every USB Cable now before sending out the Units.
I will get my Money back.
We're sorry about your issues, but we're happy that you will get your money back. We are still working hard on that fix for you all.
 

FartSicle

Member
Hi, I bought a Zen Air DAC a week ago and have encountered the exact same issue as described in the first post (latest firmware and drivers). Can easily be replicated in Windows by pressing the "Test" button in the device properties window of the sound control panel, or continuously double clicking on a playlist item in a media player such as foobar2k.

This issue can also be easily replicated by using the DAC with a PS4/PS5 console, just navigate around the main menu and most menu beep sounds will either be unplayed or have the beginning cut off.

Reported this issue to iFi support, they say it's a known problem so hopefully it can be fixed as it's a pretty severe issue.

And yes, also had an issue with a very tight USB cable (or socket), had to really pull the cable with force to remove it from the DAC. Recommend using a different cable.
@kmn140 Don't hold your breath. I also have the audio dropouts issue. I was told by iFi support "We would recommend contacting the Amazon seller for a replacement or refund of the device." So obviously they're not working on a software/firmware fix, this is a hardware issue/defect that cannot be fixed with a software update, or they wouldn't be telling me to return the unit.. And the return, of course, would be at my expense. I would stay away from this device until iFi gets this straightened out. Very disappointed that I bought this product.
 
Last edited:

Zamarius

Novice Member
Made an account to chime in: having the exact same issue with the Zen Air DAC, Windows 10, latest driver and firmware. Did some messing around in the settings and setting the output format to 16 bit at least seems to reduce the delay a fair bit. The audio test in the sound settings plays normally, but some system sounds are still somewhat choppy. Not 100% sure, but reducing the sampling rate to 44.1 kHz seems to help with that a little bit, too.
 

George Papasifakis

Novice Member
I have the same issue with my zen air dac. Youtube audio lags when i move the timebar. I miss audio from zoom calls like it enters stand-by if it does not receive signal. Also a stereo check showed that when only the left speaker plays it drops out audio but when both speakers where playing the left played with no problems. i changed to 16 bit and the issue with left channel dissapeared and youtube is lagging less but MQA is not working with this settings.
checked on both win10 and win11.

driver: 5.12.0
firmware: v7.40

i used this track for test:
 
Last edited:

iFi audio

Member
AVForums Sponsor
I have the same issue with my zen air dac. Youtube audio lags when i move the timebar. I miss audio from zoom calls like it enters stand-by if it does not receive signal. Also a stereo check showed that when only the left speaker plays it drops out audio but when both speakers where playing the left played with no problems. i changed to 16 bit and the issue with left channel dissapeared and youtube is lagging less but MQA is not working with this settings.
checked on both win10 and win11.

driver: 5.12.0
firmware: v7.40

i used this track for test:

Please send me a DM so I can help you with this issue.
 

Platinum326

Novice Member
Problem solved for me.
I contacted Ifi support and they instructed me to try the other firmware updates.
For me the firmware v7.4c worked.
Hey, did your DAC end up with yellow light? I have the same issue with v7.3, just updated to v7.4c but the led light turns into yellow (green before) and i also lost access to 48000 hz, now it's operating at 44100 hz...
 

Platinum326

Novice Member
To add this, I opened a ticket on iFi's website but the rep doesn't really help.... the following is the exact reply from the rep, honestly, a bit of let down.

''Thank you for your ticket regarding the Zen Air Dac. The device is mostly designed as a high resolution audio DAC for Music enjoyment, it is not designed to deal with multiple and conflicting audio sources on your PC at once such as watching YouTube and Gaming. This would explain the issue you are having.''
 

FartSicle

Member
To add this, I opened a ticket on iFi's website but the rep doesn't really help.... the following is the exact reply from the rep, honestly, a bit of let down.

''Thank you for your ticket regarding the Zen Air Dac. The device is mostly designed as a high resolution audio DAC for Music enjoyment, it is not designed to deal with multiple and conflicting audio sources on your PC at once such as watching YouTube and Gaming. This would explain the issue you are having.''
@Platinum326 @iFi audio Haha, yeah I got the exact same reply word for word. This must be an explanation that they brainstormed recently to try to explain this recent wave of Zen Air Dac problems in this thread and others no doubt, without taking responsibility.
My rep suggested a few times that I send it back to Amazon seller for exchange or refund. I find this odd as iFi has no idea if the problem is hardware or software, yet they think I should exchange it?
If they recommend that I should exchange it, that would indicate a hardware problem, and the product is under warranty. I just think they released this product before it was fully tested.
I'm sorry I bought it and just have a bad taste in my mouth regarding iFi Audio.
 

Platinum326

Novice Member
@Platinum326 @iFi audio Haha, yeah I got the exact same reply word for word. This must be an explanation that they brainstormed recently to try to explain this recent wave of Zen Air Dac problems in this thread and others no doubt, without taking responsibility.
My rep suggested a few times that I send it back to Amazon seller for exchange or refund. I find this odd as iFi has no idea if the problem is hardware or software, yet they think I should exchange it?
If they recommend that I should exchange it, that would indicate a hardware problem, and the product is under warranty. I just think they released this product before it was fully tested.
I'm sorry I bought it and just have a bad taste in my mouth regarding iFi Audio.
lol, i also got the faulty jack, couldn't detach the stock cable, where's the QC?
 

George Papasifakis

Novice Member
To add this, I opened a ticket on iFi's website but the rep doesn't really help.... the following is the exact reply from the rep, honestly, a bit of let down.

''Thank you for your ticket regarding the Zen Air Dac. The device is mostly designed as a high resolution audio DAC for Music enjoyment, it is not designed to deal with multiple and conflicting audio sources on your PC at once such as watching YouTube and Gaming. This would explain the issue you are having.''
No its green.
I think the color depends on what your pc outputs that time. this you can check from the ifi driver whats the current output.
I just tested with dsd files and foobar.
It did not change colors and foobar was outputting 44.1
I changed from control panel manually to 24 192000 and know also it changes colors to dsd playback .
 

Platinum326

Novice Member
No its green.
I think the color depends on what your pc outputs that time. this you can check from the ifi driver whats the current output.
I just tested with dsd files and foobar.
It did not change colors and foobar was outputting 44.1
I changed from control panel manually to 24 192000 and know also it changes colors to dsd playback .
1654110419901.png

it represents 176.4 khz and higher while my unit stuck in 44.1 khz according to the driver.
1654110520705.png
 

kmn140

Novice Member
Regarding the yellow light when using firmware 7.4c, during playback of PCM data (not DSD, not MQA), the GTO filter will internally upsample audio data which causes the yellow light. This is listed somewhere in the firmware release notes. Upgrading to 7.4c did not fix the audio dropouts for me.

Regarding the above reply from support, that answer is unacceptable since this issue occurs during non-exclusive mode, it would be somewhat understandable if running under ASIO. Also, I tried the Zen DAC Signature V2 at a retail store and it performed perfectly (!). I tried the store's Zen Air DAC and it had the exact same problems. So it really is just specific to the Air.
 

iFi audio

Member
AVForums Sponsor
To add this, I opened a ticket on iFi's website but the rep doesn't really help.... the following is the exact reply from the rep, honestly, a bit of let down.

''Thank you for your ticket regarding the Zen Air Dac. The device is mostly designed as a high resolution audio DAC for Music enjoyment, it is not designed to deal with multiple and conflicting audio sources on your PC at once such as watching YouTube and Gaming. This would explain the issue you are having.''
They probably meant problems using exclusivity modes for output devices. Please send me your ticket number in DM, I'll look into the matter.

In case you are dissatisfied with customer support on this matter please send me the ticket number, I'll look into the issue.

Before reporting the issue, please be so kind and make sure to run the newest firmware, which is v7.4.

Available here: Download Hub | Software and firmware for your iFi audio devices

v7.4 is a normal MQA version
v7.4b has MQA disabled
v7.4c has MQA enabled an GTO (oversampling) enabled

We have a LED colour calculator, Air DAC will be added soon:

About the issue with cables getting stuck in the socket, please kindly return it to the seller for a replacement unit.
 
Last edited:

lsderik

Novice Member
@FartSicle @Zamarius We're offering free, door-to-door repairs for Zen DAC Air. Send me a DM so I can arrange that. Also, please send me your support ticket numbers, so I can see what is up.
Hello. I bought the zen air dac a week ago. I have Been trying to fix audio dropouts ever since. I have used a driver uninstaller software to reinstall all audio drivers but still no luck, i have both the 5.12 software and 7.4 firmware. Do you have any sort of hail mary that i could try and see if it fixes?
 

iFi audio

Member
AVForums Sponsor
Hello. I bought the zen air dac a week ago. I have Been trying to fix audio dropouts ever since. I have used a driver uninstaller software to reinstall all audio drivers but still no luck, i have both the 5.12 software and 7.4 firmware. Do you have any sort of hail mary that i could try and see if it fixes?
Hi, I'm sorry for this issue. Please contact your dealer for a replacement unit. Sorry for the inconvenience.
 

washingmachine

Novice Member
Hello, created an account just to reply here.
My unit just came this week and been using it none stop. I encountered the delay exactly as described in earlier replies. Already updated the latest firmware and it still occurs. Tried playing with default sampling rate and I found that delay only happens with sampling rate higher than 300k. Changing this to 192k hz did resolve the delay. I thought the delay was fixed when I upgraded the firmware, but as it turns out upgrading firmware automatically sets sampling rate to 44.1k. So changing it to 384k, the delay comes back.
 

The latest video from AVForums

Samsung S95B QD OLED Review - A Quantum Leap for OLED!
Subscribe to our YouTube channel

Latest News

PSB Speakers unveils Passif 50 loudspeaker
  • By Ian Collen
  • Published
Samsung Gaming Hub goes live
  • By Ian Collen
  • Published
Huawei unveils FreeBuds Pro 2 true wireless earbuds
  • By Ian Collen
  • Published
Sony unveils Inzone gaming brand
  • By Ian Collen
  • Published
Bowers & Wilkins launches Px7 S2 wireless headphones
  • By Ian Collen
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom