1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I think I just broke my reciever

Discussion in 'AV Receivers & Amplifiers' started by UncleTimmy, Apr 7, 2002.

  1. UncleTimmy

    UncleTimmy
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    :( I think I just bust my reciever. It was a Sherwood 925 RDS. I put some music on, turned it up to about half way and all of a sudden the was quite a big bang and then white noise from the speakers. I turned everything off and then waited and turned it back on. Now the Front channel doesn't work. The speakers are fine though. It also appears to have absolutley mangled a whitenoise mos125 power amp as well, and that was home built and not guaranteed. Are there any lessons to be learnt from this? (Don't build your own power amps?)...

    The power amp was on a line out and the reciever front channel amp doesn't work either. I can take it to the shop I think and get a refund, but I was just wondering if I had done something stupid and theres some way of reseting something?
     
  2. UncleTimmy

    UncleTimmy
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    OKay guy's I took my receiver back to the shop. It's broken. And They gave me a refund!

    Okay: Any suggestions on kit? For a limited budget to £230 quid because I'm a student, I'm poor, and I have no other money. I don't really think It's worth spending thousands of pounds on it either? Two words: "Gig Tickets".

    Um... I'm looking at the Sony STRDE875, And at the moment I have a Sherwood 7103R until I can find a nice tasty one.
     

Share This Page

Loading...